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1.0 Overview

1.1 Introduction

Flight Manager is a user-friendly application for handling flight information and scheduling. It
provides easy access to flight and scheduling data for airport operators, handler operators,
floor managers and information desks. Flight Manager is a Graphic User Interface (GUI) that
allows you to insert, schedule, update and delete flight data.

Flight Manager offers the following benefits:
- Security

» Access is restricted to user names and encrypted passwords stored in the USERS
database table.

» Restricted access to flights based on a user’s flight handler specified in the USERS
database table.

» If the handler in the USERS database table has no value; the user can operate
flights for ALL handlers and airlines.

- Internationalization - All text/labels (e.g. menu items, buttons, labels, etc.) are
internationalized.

- Filtering - Viewing flight information according to user specified requirements

This document is a guide. The System Administrator needs to make or add site specific
changes as required.

1.2 Why Do | Need To Use Flight Manager?
Flight Manager is used by two types of users (System Administrators and General Operators),
for different reasons.

-~ System Administrators use Flight Manager to configure and set Flight Manager to the
special requirements and operational needs of the airport.

- General Operators (airline and airport operations staff) use Flight Manager to:
» Create, change and update flights
» Handle resources such as gates, belts and carousels linked to flights

= Handle desk allocations
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1.3 Document Conventions

The following conventions are used in this document:
& Keys referred to in procedures are displayed in bold and have an initial capital.
Example: Press Return.

&  Menu selections, buttons, and check boxes referred to in procedures are
displayed in bold and have an initial capital.

Example: Choose either OK to replace the existing file or Cancel to abort the
action.

&  Data or commands that must be typed exactly as they appear are represented
in Gotham Black type.

Example: Type als in the Value text box and click the OK button to locate any
value beginning with als.

& When you must perform two or more steps to select a menu option, the steps
are condensed by using an arrow (=2) to indicate the menu path. Example: To
choose the image viewer:

1. Select File 2 Exit

»  References to section and chapter titles are shown in a bolder, more defined
text.

Example: For more information refer to Using Filters on page 28.

&  Warnings indicate specific issues and procedures that could result in loss of
data or equipment damage, etc. Use a block red box as a warning box, as seen
in Section 3.

Example:

=  Notes clarify issues and procedures and help ensure a better understanding of
the product and its functions.

Note: The print function can also be accessed from the toolbar.
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2.0 Key Concepts

2.1 Flight Manager Functionality

Flight information is viewed and handled using the following perspectives:
-~ Flights

»~ Resources

= Desk allocations

- Scheduling

- DB Table (Depending upon user permissions)
2.2 Flights Screen

The Flights Screen displays all the available flights (from the flights tables), according to the
filter chosen (see Using Filters page 79).

. InterSystems Flight Manager - Flights [Test] @@@

File  Edit  View Tasks Actions Favorites Tools  Window  Help - 8 X

-8 S BB DHAOX T2 # ¢
<all> v | [4]A Date » Airline Flight No Locations - -
‘\j <all> v| @b | <all> v |<all> v [<allz

@) SQL:
@ | Carousels Desks Details Comments/Remarks Yisits
General \ Passengers Info Handlers Locations (via's) Belts Gates
Resources = - B
Oper, Date Flight No. Leg Info | Gate Gate2  Sch, Time Est Time
1 [02/06/2006|BI074 D P | 02/06/2006 13:50 02/06/2006 13:50 A
2 02/06/2006 NF020 A P 02/06/2006 11:00 02/06/2006 11:00
0z/06/2006 QF175 D P 0z/06/2006 12:10 02/06/2006 11:10%
< >
\Tq E‘—l’? P 02/06{2006 BI074 departure 4735 rows
,= | I Open Gate " Boarding |[ Last Call || Close Gate || Off Blocks " Departed

| & admin | €8 admin |

Figure 1: Flights Screen
The Flights Screen usually consists of the following tabbed panes:
- Belts - All information regarding flight belt usage.
- Carousels - All information regarding flight carousel usage.

- Comments/Remarks - All information regarding public and staff comments and flight
status remarks.

Desks - All information regarding flight desk allocations.

Details - Crew, Quarantine code, Mail, Ground power, Pre-conditioned air, Aircraft type
code, Aircraft code, Nature code, Range code, Remark value, Remark last update
date/time, Status code, Delay code, Fuel, Burn, Terminal name, Previous terminal, Public
comment, Staff comment, Short staff comment, On-off block date/time of flights.

Gates - all information regarding the gate usage of flights.
General - flight key and time information.

Handlers - all information regarding the handlers of flights.
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- Locations (via’s) - all information regarding origin or destination of flights.

- Passengers Info - all information about flight pax.
- Visits - all information regarding flight bay usage.

The Flight screen usually provides the following functionality:

- Inserting a new flight

- Deleting a flight

~ Updating/viewing a flight

- Filtering the flights view via filters and Structured Query Language (SQL) queries

- Performing specific actions for flights (e.g. open/close gate, belt first/last bag, carousel

first/last bag, boarding/last call, on blocks/landed, link)

2.3 Resources Screens
The Resources screens display all the Gates, Belts and Carousels attached to a flight. Using
these windows you can perform the following actions:
- Update the resource usage information.

- Change the resource (for example, change the gate for a specific flight).

- Clear all the resource usage information and remove the relevant flight from a specific
resource.

-~ Filter the resource view.
2.4 Desks Allocations Screen

The Desks Allocations screen deals with allocating specific flights, passenger classes and
carriers to a desk(s). The data from the database table will display in the desk window.
Flights, classes and carriers can be associated with desk allocations or existing associations
can be removed (i.e. disassociate a flight, class or carrier from a desk allocation).

In the desks window you can perform the following actions:
- Create new desk allocations.
- Remove existing desk allocations.

- Modify the details of existing desk allocations.
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2.5 Scheduling

From Scheduling you may choose Primary Flights Scheduling, Codeshares Scheduling, Visits
Scheduling or Desks Scheduling.

All the data needed to schedule a flight is stored and managed in the schedule tables of the
database. The data contains the same flight information stored in the flight tables (without
unknown data, e.g. the actual time, etc.). The schedules created are seasonal, and the system
stores them as such.

2.5.1 Primary Flights Scheduling

The Primary Flights Scheduling screen stores flight schedule data. Using this data, Primary
Flights Scheduling creates flight records, also known as “Daily Flights”.

%. InterSystems Flight Manager - Primary Flights Scheduling [CurrentSeason] Q@@
File  Edit  View  Tasks  Actions Favorites Tools  Window  Help - 8 X

-8 S0 BREB DFRX T2 ¢ QG
A Airline Flight Mo Yalid Dates »>  Weekdays Exclude =
,} D |<al> v|| | [<all> v|lcal> )

O sqLu
@ General | Handlers | Locations (via's) | Belts | Gates Carousels | Details | Visits
PSS Flt No Leg Info Weekdays Valid From Date Yalid To Date Season Name  Exclude Locatic
1 CX995 & 1234567 Z26/03/2006 3171072006 806 HLZ A&
2 CKX996 A& 1234567 Z26/03/2006 3171072006 S06 HOF
3 CX997 A 1234567 Z26/03/2006 3171072006 S06 HOB
4 AZ765 A dbootlooo 26/03/2006 3171072006 806 N ABC
3 ER316 D 1..4.67 26/03/2006 3171072006 806 TPE -
- fATArA S LI N e T W Yo Ta Pl ar crincinnns ens T
< >
Scheduling .-+ {additional information) 1442 rows
- | | || validate Al |
ﬂ l £ admin I €& admin I

Figure 2: Primary Flight Scheduling Screen
The Scheduling screen usually provides the following functionality:
- Creating and validating a new schedule.
- Editing schedule information.

- Deleting schedule information.

Note: You can validate a schedule by clicking the Validate button. This verifies if there is a
conflict with other already created schedules.
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2.5.2 Scheduling Codeshares

The Codeshares Scheduling screen is in charge of storing the Codeshares flight schedule
data. This allows you to create a seasonal schedule according to the date, weekdays, airline

etc.

%. InterSystems Flight Manager - Codeshares Scheduling [default] E]@@
File  Edit View Tasks Actions Favorites Tools  Window  Help - 8 X
=-8 S0 BB RFRX T2 ¢ Q¢

[V]a Primary Flight Aitline Primary Flight No Yalid Dates »> Weeki

22 | Bo [ ¥ I | .

O sqL:
@ [ General

Flt Number Leg Weekdays Sec Flt No Valid From Date Valid To Date Sec 1 Wial Sec 1 Vi:
Resources

1 QFlo D ...45.. 07/03/2005  12/03/2005 ~

2z QFlsz A 1234567 BA7354 17/12/2000  30/03/2002 SIN =

3 QF0S51 A 2.7 BA7351 3170372002 zz/l0/z00z CHNS

4 NFO0ZO A 1...5.7 QF373 31/10/1999  26/03/2000 VLI

5 CXloz a _.4..7 CXl03 27/10/2002  28/03/2003 HKG CHs

3 JL762 D 1234567 QF369 31/10/1999 Z26/03/2000 NRT V]

| <l >
Scheduling 877 rows

ﬂ | £ admin |=_ﬁ admin |

Figure 3: Codeshares Scheduling screen
2.5.3 Visits Scheduling

The Visits Scheduling screen displays flight visit information and is read-only.

%. InterSystems Flight Manager - Visits Scheduling [itamir] Q@@
File  Edit View  Tasks Actions Favorites Tools Window  Help - 8 X
=-B S 2B DR X T2 ¢#¢ Q0
A Flight Mo Valid Dates »> Exclude Weekdays Bay Season
“ | |<all= [ | [<all> v |zall> ,

Flights O squ

@ [ General
Arr Valid From Date Arr Valid To Date Arr Weekdays Arr Exclude Arr Bay Park1 Bay Dep Yalid F

Resources | 1 0l/1z/z004 10/01/20058 1234567 1 0l/1z/20
2 0z/12/z004 11/01/2005 1234567 1 z

< 2|

: 2 rows

| '.E | | Validate
ﬂ | & admin | € admin |

Figure 4: Visits Scheduling Screen
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2.5.4

Desks Scheduling

The Desks Scheduling screen displays desk allocation schedule information.

%. InterSystems Flight Manager, - Desks Scheduling [Sch Desks]

File  Edit

=-8

Flights

View  Tasks  Actions Favorites Tools Window  Help
G BB RHFLOX T2 /¢ AG
Date »> Desk Handler Carrier
» | [<all> v |zall> v | |<al> v
@) SQL:’ v

EBX

- 8 X

Clear

&

Resources

Scheduling

DB Table

Soton)
11

WO W s W N e

—
=

General |

Desk Name Valid From Date

1blb
1bd

555

1blb
1blb
1blb
1blb
1blb
1blb

17
&

07MARZOO7
Z6JANZ007
Z7JANZ007
07MARZOO7
07MARZOO7
0SMARZOO7
Z1MARZOO7
Z3MARZOO7
Z6JANZ007
0ZDECZ003

Valid To Date Weekdays Sch Open Time
1234567 0s:
1234567 'Q=

30AUGZ007
O1MARZOO7
01MARZOO7
O01APRZOO7
O1APRZOO7
1eMARZOO7
Z1MARZODO7
30AUGZ007
01MARZOO7
03JANZO04

.23456. 10:
1234567 09:
1234567 10:
..... &7 09:
< e 09:
..... &7 0S:

1234567 09:
1234567 12:

45
oo
oo
oo
oo
0o
oo
45
ulu]
30

Sch Close Time Handler E
09:
11:
11:
10:
11:
10:
10:
AN
10:
16:

oo
oo
alu]
oo
oo
0o
uli]
uli]
ulu]
30

Desk Details

=

~
AN -
>

.3

EIN

v

30 rows

|2 admin rﬁ admin |

Figure 5: Desks Scheduling Screen

This screen usually provides the following functionality:

- Creating and validating new desk allocation schedules.

-~ Editing schedule information.

- Deleting schedule information.

2.6

DB Table

Flight Manager can manage several database tables through the "DB Table” view. To enable
this option a User Defined View (UDV) must be created.

The DB Table view is intended to give the user (usually an administrator) access to database
tables like AIRLINES, HANDLERS, LOCATIONS, GATES and other look-up tables. The DB
Table windows do not replace other windows in the Flight Manager and can't be used to
operate flights, desks or work with other database tables that are intended to be operated by
specific RapidAIMS applications.
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%. Open system view @

Select from one of the available views below
= admin
Handlers
Airlines
Handler Access
(= default
Airline Messages
Padium Signs

[ OK H Cancel I

Figure 6: DB Table Screen

Flight Manager Views

System View
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A System View is a generic predefined view prepared by the system administrator, including
information used by airport operators. An operator cannot make changes to the System View
itself, but can customize this view according to individual preferences (see Views below).

System Views can have a filter already attached by the system administrator. If this is the
case, the view opens displaying the data ready to work.

When choosing flights, resources, desks or scheduling (by clicking the appropriate button),
the view displayed is the “default” view defined by the system administrator.

To access system views:

1. Choose File > Open System View.

2. Select the desired system view.
3. Click the OK button to open the view.

Copyright © InterSystems 2011

RapidAIMS Flight Manager USM- v 5.3.4

Page 19 of 108



V 4 systems

‘ ingenious by design

2.7.2 Views

. Open system view @

Select from one of the available ...

=+ 54 Flights
=+ admin
=~ & admin
L valery
MoFilter
Carousel Daily
=+ default
L flights
[+ §° Gates Usage
[+ @ Belts Usage
IEF * Carousels Usage
# i Desks
#+- | Primary Flights Scheduling
#- }#] Codeshares Scheduling
- 4" Visits Scheduling

Figure 7: System View Selection

A View is a customized view saved on your local drive (the default save location is the My
Documents folder). The view saves column properties (like column width) and last used filter.
You can make changes to the view at any time and save the new view with a customized
name in order to identify the view later. See Saving a Custom View on page 92 for more

information.

2.8 Filters

Filters allow you to view flights and flight related information (such as resources, desks or
scheduling) according to your preferences. Filters use SQL based statements to create a
view, which can then be saved with a specific name. When using a filter, it can include
dynamic parameters, prompting for values each time the filter is used (for more information
on how to manipulate a filter, see Using Filters page 79).
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3.0 Accessing Flight Manager

3.1 Starting Flight Manager

Start Flight Manager by using one of the following methods:

- To access Flight Manager from the desktop or taskbar:

» Click the Flight Manager icon located in either location.
-~ To open Flight Manager from the Start Menu:

1. Click the Start button.
The Start Menu will open.

i »
2. Select the RapidAIMS button on the right side of the

menu (Figure 8).

L= . . n
3. Click the Flight Managerl E] FlightiManager.jar |button.
The Flight Manager Login dialog box will open.

é Internet J My Documents

Internet Explorer
:), My Recent Documents »

Ve 5] E-mail
\JJ' Outlook Express 2
‘ 2 - RapidAIMS I ] FlightManager.jar

.
. FreeTextTicket.exe ) My Music

Set Program Access and ;‘/g My Computer ’

Defaults

G) Control Panel
@ ‘Windows Media Player

@ Set Program Access and
Defaults

\’ MSN {3 Printers and Faxes
=

“3 Windows Messenger 9) Bielp e S0ppert
@) Tour Windows XP /) Search

{—7 Run...
Command Prompt

7
J Windows Security
All Programs D

1 - Log Off Disconnect

= i C:A

Figure 8: Opening Flight Manager
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3.2 Flight Manager Login

Security is strictly applied in RapidAIMS. A username and password is always required to gain
access.
Once the Flight Manager Login dialog box (Figure 9) has opened:

1. Enter your User name and Password.

2. Click OK.

Flight Manager Login

. |‘ '\
r— = N %
£ Please specify user name and password \ ‘E 2

3 /r {both are case sensitive). - 0

User name: ' adrmin |

Password: | | l

| QK | I Cancel | | Options == |

Figure 9: Flight Manager Login
3. The Flight Manager window will open.

3.3 Exiting Flight Manager

To exit the Flight Manager, select one of the following methods:

-~ Select File - Exit from the menu.

-~ Click the Close button in the top right corner of the screen.
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4.0 Working with Flight Manager

4.1 Window Structure

The structure of a typical window is shown below.

. InterSystems Flight Manager. - Flights [default]

File ~ Edit WView  Tasks  Actions Favorites Tools  Window  Help - 8 X
-8 0 BE DEFDOX T2 74 Q@
f \( <all= v | [v]A Date » Airline Flight No Locations
3 <all> v| o <all> v <all> v |<al>
Flights
Tasks Q soL:
Bar
@ f Gates . Carousels Desks Details Comments/Remarks
General ‘ Passengers Info Handlers Locations (via's)
Resources = =
Oper, Date Flight No. Leg Info Bay Gate Carousel Belt Sch, Time
1 19/01/2009 UALlll A S @ |D30 D30 1 19/01/2009 Z3:
2 13/01/2002|UALLS0 A P+ @ |D30 D30 1 19/01/2009 23:
3 19/01/2009 TZ496Z D P & |Dl13 D13 ? 19/01/2009 0S:
4 19/01/2009 US4094 D P @ |D24 Dz4 4 19/01/2009 09:
s 19/01/2009 UAZES D P @ |D30 D30 5 19/01/2009 07:
3 19/01/2009 UAL9S D P @ |DlS D1sS al 19/01/2009 06:
7 19/01/2009 US103 D P & |Dll D1l 3 19/01/2009 07:
8 19/01/2009 USZEe31 D P &|Dl4 Dl4 3 19/01/2009 06:
k 19/01/2009 UA7Z88 D P @ |D20 Dzo s 19/01/2009 06:
g4
G4 P, @ 19/01/2009 UA1190 arrival . secondary: UA1111 145 rows Action
I pen Gate " Boarding ” aate Final Cal ” ose Gate I On Blocks ” Landed | @ Bar
—
| | £ admin | €8 admin | #¥ | 7887KB (12%) of 8MB [max. 63MB] |2
— o
System
Info
Figure 10: Window Structure
4.2 Views

Flight Manager has two views “Grid View” and “Detail View”. Information in the grid view is
normally limited to the most frequently used information. The Detail View is used to view the
details of different records in the database.

4.3 Grid View

The grid view displays multiple records from database tables.

- Each column represents a field from the database table.

- Each row represents a record from the database table.

4.3.1 Tasks Bar

The Tasks Bar allows you to select the functions of flight manager. Not all functions are
available to every user.
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4.3.2 Query Panel

The Query Panel allows users to view flights according to date, flight number, airline, etc.

<all= v [V]A Date » Airline Flight Mo Locations Gate Remark Wisit
© <all> v| [v]lD <all> v <all> v | <all> v | <all> v | |<all> v
O sqL: 3

Figure 11: Query Panel

Example: To view primary arrival flights on a specific day:

C :]Primary z A) Date > A
¥ <all> v| 0o (isjozjz005_)|<all> \

Figure 12: Query Panel Example
1. Select Primary.
2. Check ¥ the A checkbox.
3. Enter the appropriate date in the date field.
4. Click the Query Now ﬂl button to confirm your choices.

For more information on how to customize the Flights view, see the section
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Customizing Flight Manager on page 89.

Note: The selections specified in the query panel are in addition to the currently used
filter. If a conflict exists between the filter and the query values, no data will display.

4.3.2.1 SQL Field

Use the SQL field to write a legal SQL statement which defines the exact data to be
displayed.

V 5oL |lec ="' v SQL wizard button

Figure 13: SQL Field

Example: If both arrival and departure flights are displayed and you want to view only the
departure flights.

1. Type LEG ='D' in the SQL field.
OR

2. Use the SQL wizard to help you write the statement.

3. Click the Query Now i@ =] hytton to confirm your choices.
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Note: For more information about using the SQL Wizard refer to the section
Usina the SQL Wizard on naae 84.

4.3.3 Flight Information

The Flight Information area contains data pertaining to the displayed flights. A row
identification number and key field values identify each record.

4.3.4 Info/Status Bar

The Status Bar displays additional data such as whether the flight is an arrival or departure
flight, a primary or secondary flight, etc.

4.3.5 Action Bar

The Action Bar contains buttons allowing you to change the flight status. For example,
opening and closing gates or desks. Only applicable buttons will be available depending upon
the view being displayed and whether or not the flight is an arrival or departure.

4.3.6 System Information

This information displays your user ID, security group, network connection status, and
optionally the memory status.

UserlD Network Status

\

& admin | €8 admin | #* |7857KE (12%) of BMB [max. 63ME] |22 |

Security Group Memory Status

4.3.7 Moving Through the Grid View

Use any of the following methods to move through the grid view:
n The mouse
- Arrow keys

-~ Scroll bars
4.3.8 Sorting the Grid View

To sort the data while using the grid view:
1. Click a column title

2. The information will be sorted based on the selected column.
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4.3.9 Editing in Grid View

You may edit a record while in the grid view. To edit a record:
1. Find the record you wish to edit.
2. Click the field you wish to change.
3. Enter your changes.

If you have not chosen to use "Auto Save”, a confirmation box will open when you move to
the next record asking if you want to save changes you have made.

Note: To turn on Auto Save mode, select Edit > Auto Save from the menu.

4.4 Detail View

The detail view may show more fields of an individual record, depending upon system
configuration of the default screen. These fields can be organized into groups of related data
which are displayed on different tabs in the detail view (Contact your system administrator
for changes).

Records can be edited or inserted in the detail view according to your security settings.
4.41 Selecting the Detail View of a Record

1. Click on any field in a record to select that record (the record will be highlighted).
2. Open the detail view using any of the following methods:
B Select Edit & Edit Flight
or
Edit 2 View Flight
Click the Edit Flight or View Flight @ button in the toolbar menu.
Double-click the selected record.

&  Right-click the selected record, then select Edit Flight or View flight from the
context menu.

3. The Detail View for the chosen record will display.
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. Update Flight 3

BI074 departure

|_Carousels | Desks | Details | Comments/Remarks | Visits
General | Passengers Info | Handlers | Locations (via's) | Belts | Gates

Scheduled Time | 02/06/2006 13:50 |
Estimated Time | 02/06/2006 13:50 |
Actual time ’ ‘
Aircraft Type 763 v
Carousel [—v|
Ronge
S
Status
Mature

| oK || Cancel |

I! |£ admin |=_ﬁ admin |

Figure 14: Detail View Example
4.4.2 Moving Through the Detail View
To move from one tab group to another, click the tab headings or use the left or right arrow
key once tab headings are in focus.
To move through the fields in a tab group, use any of the following methods:
»~ The Tab key
-~ The mouse

-~ Arrow keys
4.4.3 Closing the Detail View

To close the detail view, use any of the following methods:

1. Click the Close @] button in the top right corner of the window to close the detail
view without saving changes to a record,;

2. Click OK to save changes to the record and close the detail view;

3. Click Cancel to close the detail view without saving changes to the record.
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4.5 Switching Between Views

You may have many views/windows open at the same time in Flight Manager. The title bar at
the top of the screen shows you the name of the Module/Task and the name of the view you

have opened. This information is useful if you have several views open at once and you want
to switch between views.

%. InterSystems Flight Manager - Flights [Today’s Flights] *

Task Name  View Name  Asterisk (*) appears whenever values

specified in the query panel are
different from the filter's values

Figure 15: Title Bar
To switch between views:

1. Select the Window menu.

2. At the bottom of the window menu there is a list of available views.

Window l Help

] Tile

= Tile Horizontally

[T] Tile vertically

(™ cascade

L Flights [Test]

W Gates Usage Available
[ Belts Usage Views

& Desks Allocations [4ll]

Figure 16: Windows Menu
3. Click the desired view.

4. The selected view will display.
4.6 Manual Refresh

The information displayed in grid view is refreshed automatically on a regular basis.

You can also refresh the information manually to ensure that information is up-to-date. To
refresh the information manually choose one of the following:

=~ Select View = Refresh
&,
Click the Refresh icon on the toolbar.

Wait for the grid to refresh. The amount of time this takes varies depending upon the
amount of data processed.
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4.7 Bulk Deletes

This feature allows you to select and delete multiple rows (records) in one operation. Select
rows by clicking on row headings

1.  Select the rows you wish to delete (See Row Selection below).
2. Use one of the following methods to delete the information.
a. Select Edit 2Delete.

b. Click the Delete button on the toolbar.

3. A Confirm Delete window will open.

Confirm Delete @

P You have chosen to delete 8 flights.

For each primary flight all corresponding codeshare flights will also be deleted.
For codeshare flights which primary flight was not selected the corresponding
primary Flight will remain in the database and will not be deleted.

Do you want to delete these flights from the database?

Figure 17: Bulk Delete Flight Confirmation
4. Click OK to accept or Cancel to abort the task.

4.7.1 Row Selection
There are two methods used to select rows in Grid View.
4.7.1.1 Selecting Adjacent Rows

To select adjacent rows:
1. Select the row heading of the first row.
2. Hold down the Shift key.

3. Select the last row.
4.7.1.2 Selecting nonadjacent Rows

1. Select the row heading of the first row.
2. Hold down the CTRL key.

3. Select the remaining rows one at a time by clicking on their row headings.

Page 30 of 108 RapidAIMS Flight Manager USM- v 5.3.4 Copyright © InterSystems 2011



Y 4 systems

ingenious by design

5.0 Data Entry

51 Mandatory Fields

Each record has a number of mandatory fields. These fields are highlighted in pink and/or
have Red field titles.

You cannot save a record before you have entered information in the mandatory fields or if
the format is incorrect. The OK button will remain grayed out as long as you have incorrect or
missing data.

52 Data Types

The following table shows different acceptable (but not restricted to) formats of data
insertion in RapidAIMS. Flight Manager may be configured to accept and display dates in
different formats. Depending upon your system settings you may enter dates with the month
first or the Day first. The table below shows some examples written with the Day entered
before the Month. Please consult your system administrator if you have any questions about
your system’s date settings.

Data Type Valid Values Example

Alphanumeric | Enter any letter or number: diverted, IEE2606
A-Z, 0-9

Integer Enter any whole number 968
(positive or negative) -45

Date Enter a date in one of the 21-04-06
following formats: DDMMYY, | 21/04/06
DDMMMYY 21APROG6

210406

Time Enter time in the following 10:00 or 1000
format HHMM

Datetime Any combination of date and | 21APRO6 10:00
time (separated by a space)

Table 1. Data Type Samples
5.3 Entering Dates and Times

Date and time fields have several short cuts and relationships that allow you to enter data
quickly and efficiently. When you edit a Date/Time field you can enter the time without the
date. Flight Manager calculates the date using an existing value in a related field or the
current day.

5.3.1 Midnight

Flight Manager knows how to handle time near midnight. For example if the Estimated Time
for a flight is 23:50 and the time entered into the Actual Time field is 00:05, Flight manager
will enter the next day for the actual date.
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5.3.2 Date/Time Fields
5.3.2.1 Scheduled Time

When entering information into the “Scheduled Time” field you only need to enter a time.
Today’s date is entered automatically when you press Enter or move your cursor to the next
field.

5.3.2.2 Estimated Time

The “Scheduled Time” field’s date is the basis for the “Estimated Time” field. If you enter just a
time in the “Estimated Time” field Flight Manager will automatically enter the date that is
contained in the “Scheduled Time” field when you press Enter or move your cursor to another
field.

5.3.2.3 Actual Time

The “Estimated Time” field’s date is the basis for the “Actual Time” field. If you enter just a
time in the “Actual Time” field Flight Manager will automatically enter the date that is
contained in the “Estimated Time” field when you press Enter or move your cursor to another
field.

5.3.2.4 Examples:

For these examples, assume that today’s date is September 25, 2006.

1. You enter the time 0825 into the Scheduled Time field for a flight.
Result: Flight Manager places 25/09/2006 08:25 in the Scheduled Time field.

2. Your Scheduled Time for a flight is 25/10/2006 13:55. You enter 1325 into the
“Estimated Time” field.
Result: Flight Manager places 25/10/2006 13:25 in the “Estimated Time” Field.

3. Scheduled Time: 25/09/2006 11:30
Estimated Time: 25/10/2006 00:25
You enter 0025 into the “Actual Time” field.
Result: Flight Manager places 25/10/2006 00:25 in the “Actual Time” field.

5.4 Date/Time Shortcuts
5.4.1 Numeric Operations/Special Symbols

The special symbols “=”, “+” and “-“ can be used while entering information into some fields.

The Scheduled Time, Estimated Time, Actual Time and On/Off Blocks Time are examples of
fields that may use these special symbols.

5.4.1.1 Equal “=" sign

The Equal “=” sign indicates that the value of the field should be the same as some another
field.
Example: Entering the equal “=” sign in the Actual Time field, will result in Flight Manager

assign it the same time as Estimated Time field.
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5.4.1.2 Plus “+” Symbol
The Plus “+” Symbol indicates that the value of the field should be greater by a given number
entered after the “+” symbol.
Example: Entering “+5” for the “On Blocks Time” means that the “On Blocks Time” should be
five minutes greater than the “Actual Time”.

5.4.1.3 Minus “-“ Symbol
The Minus “-” Symbol indicates that the value of the field should be less by a given number
entered after the “-” symbol.
Example: Entering “-10” for the “Estimated Time” means that the “Estimated Time” should be
ten minutes less than the “Scheduled Time”.

5.4.2 Keywords

You can use the following keywords to insert data into a date/time field:

- today or t - inserts today’s date in a date field or the current date and time into a
Date/Time field.

=~ now or n - inserts the current time in a time field or the current date and time into a
Date/Time field.

The special symbols can also be used with the today, t, now and n keywords. You can use
positive or negative numbers to add or subtract from the current date or time.

For example, if you enter:
t +1-tomorrow’s date is entered into the system
t - 2 - the date two days before today’s date is entered into the system
n + 30 - a time 30 minutes from the current time is entered into the system

n - 20 - a time 20 minutes before the current time is entered into the system
5.5 Drop Down Lists

A number of fields contain drop down lists. They can be identified by the drop down list
arrow next to them.

'[l.‘\Aircraft Type v
N\ [72s ~

\ 74E
| [F4F v

Figure 18: Drop Down List
To select an item from a drop down list:
1. Click the drop down arrow.

2. A list of options will display.
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3. Scroll through the list and click the desired option.

Note: To change your selection to a blank field, select the blank space at the top or
bottom of the list.

5.6 Copy/Paste Method

This method allows you to create a new record by copying an existing record.

Note: You can use the Copy/Paste method for the Flights, Resources, Desks and
Scheduling modules.

1. Select a record.

Click the Copy button.

2.

3. Click the Paste @ button.

4. The Insert window will open displaying the copied information.
5. Change information as needed for the new record.

6. Click OK to approve, or Cancel to abort the task.
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6.0 Print Options

You have two options for printing the rows displayed in a view. The total number of rows is
displayed on the right side of the info/status bar.

If the number of records exceeds the effective viewed area, the printout is divided into a
number of printed pages.

6.1 Printing All Pages

To print all the pages:
4
=~ Choose File 2>Print or click the Print icon on the toolbar

Note: The standard print dialog box will NOT display and the information will print without
further notice.

6.2 Printing a Selection

If you choose to print a selection of rows only:
1.  Choose File & Print Preview or click the Print Preview icon on the toolbar.
2. The print preview window will open.
3. Select the desired page using the First, Last, Previous or the Next buttons.
4

Click the Print button to print the chosen page or click the Print All button to print all
the pages.

5. Click the Close button to exit Print Preview and go back to the main application.
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View Name

Page navigation
Buttons

single page

Close print preview

Print Print all pages

B Flights [Toda, ‘s Flights) - Print Previc +

within range

dialog and return
to main window

[ prevous | dext | it Jooe | omem O |

G rrd

Tab name

General

=i * Mo Leg Schadided Aevivil Dspwrtire Term £t Tera Actusl Tene  Alrcra® Typa Code

2% |05/01/2008 204 O 05/01/2008 05:30 05/01/200% 05:30 7R
29 |05/01/2005 X004 D 05/01/2005 10:5§ 05/01/2005 10:5%5 763
30 (0570172008 NT136¢ D 05/01/2008 11:40 05/01/2005 11:40 T44
31 |05/01/2008 DJ9S0O3 A 0S/01/2008 10:45 05/01/2008 10:45 73R
32 (0570072008 DJ203 A 05/01/2008 06:55 05/01/2005 06:5§ 73R
33 (0570172008 3Q25¢ D 05/01/2008 10:8% 05/01/72008 10:5% 702
a“ VB/VAZEWS AB/W A VBIVAIEUNS AW V/VALEWDS Al 9
4 (05/01/2008 3Q245 A 05/01/2008 19:30 05/01/2008 20:08 2
& |05/01/2008 DJ22Z D 05/01/2005 09:00 05/01/2005 09:00 73R
& |(05/01/200% N¥7001 D 05/01/2008 10:00 05/01/7200% 10:00 7
& |05/01/2008 3B151 D 05/01/2005 19:30 05/01/2008 19:30 320
& |(0S/01/2008 X430 D 05/01/2008 07:50 05/01/2005 07:50 773
4 (0570172008 Qrosy o 05/01/2008 14:18 05/01/2008 14:18 743

1d 05/01/2008 17:30 05/01/2008 17:30 733

'Wed, 5 Jan 2005 14:4203 |
>
Page 3 of 16 -
) Page number/Total
Date/Time of printout number of pages

Figure 19: Print Preview Window
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7.1

Opening the Flights View

To Open the Flights view:
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1. If the Flights view is not currently open, use one of the following methods to open it:

e
& Click the Flights lres| button on the Task Bar.
B Select Tasks 2> Flights.

2. The Flights view will open.

¥. InterSystems Flight Manager - Primary Flights Scheduling [CurrentSeason]

File  Edit

Flights

&

Resources

Free Text

View  Tasks  Action

A Airline

D <all> v

s  Favorites

Tools  Window

'=>-8 QA RB DERX T2 o

Flight No Valid Dates > ‘\Weekdays

[l

| |

Help

@ @

Exclude

Season

| [<all>

v | |<all>

O so

:
Clear

Flt No Leg
CK9395
CX996
CX9397
AZ765
BR316
CIOS3
CIOS4
CcXloz
cXloz
BIO71

WO N N bW N e
=N I~T I - T N N

—-
o

..+ {additional information)

.Genel’a']Handlers Locations (via's) | Belts | Gates | Carousels | Details | Yisits

Exclude Location Location z

Info Weekdays Valid From Date Valid To Date Season Name

1234567 2670372006 31/10/2006 S06 HLZ
1234567 Z6/03/2006 31/10/2006 S06 HOF
1234567 Z6/03/2008 31/10/2006 S06 HOE
dbo oClo o0 2670372008 31/10/2006 S06 N AEC
1l..4.67 2670372006 31/10/2006 S06 TPE
.2.45_7 2670372006 31/10/z2006 S06 TPE
.2.45.7 2670372006 31/10/2006 S06 TPE

.3..6 2670372006 31/10/2006 S06 CNS
1lz.45.7 2670372006 31/10/2006 S06 HEG
..... 6. 2670372006 31/10/2006 S06 AKL
<

[ veidee || validate Al |

]
=)

v|
>

1442 rows

| & admin [E admin

3. Use the Filter option to view the information.

Figure 20: Flights View

To open the Database Filters window use one of the following methods.

&  Select View >Filters from the Menu bar

& Click the Filters ? button on the tool bar.
m  Use the keyboard, CTRL+R.
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4. The Filters window will open.

. Database Filters - FLTO_VIEW X

File  Edit Help
DX X @
€ ©Group: ladmin v £ Ousen
Name Description
3 mySAT_flights ~
4 SAT FLTU SAT
5 SAT-Saitlines
& SAT-QF-TG For YISITS linkfunlink test
7 SAT_AIRLINES SAT FILTER
8 Today Flights Today flights
9 Today's Flights
10 TodayArr Today Arrival flights
11 TodayDep Today Departure flights
12 TodayDep EI Today EI departures
13 Tomorrow Tomorrow flights o
| LEG = 'A' and OPER _DATE = today | & admin | € admin |
=

Figure 21: Database Filters
5. Select a filter.
6. Click the OK button to approve the selection.

You can further refine the data in your view by using the Query or SQL panels. All queries are
restricted to the data in the current view. Security settings cannot be compromised by using
filters.

For more information on how to manipulate filters see Using Filters on page 79.
7.2 Inserting a New Flight

The Insert Flight option allows you to insert a new flight into the table including related data
such as Passenger Info, Handler Name, Location of the flight, Belt, etc.

7.2.1 Opening the Insert Flight Window

1. Toinsert a new flight choose one of the following methods.
e Select Edit 2 Insert Flight from the menu.

e Right-click any flight record and select Insert Record from the context menu.

e Click the Insert Flight button on the toolbar.

2. The Insert Flight window will open.
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A -
New Flight
Carousels Desks Details Comments/Remarks Yisit

General | passengers Info | Handlers | Locations (via's) | Belts | Gates
Oper Date 15022005 Codesharing ~
airline 1EE v 1) This is a primary flight
Flight Mumeric If you wish to make it a secondary flight
Leg A v] please select its related primary:
Sch Time 15/02/2005 20:20 l N

Est time |

Actual time ‘

Aircraft Type v

= . r =l v
< >

| OK | | Cancel |
ll | € admin | €8 admin |

Figure 22: Insert Flight Window

3. Enter the required flight data using one of the following two methods (Insert or
Copy/Paste).

7.2.2 Insert Method

1. Enter the Flight information. Operational Date, Airline, Flight Number, Leg and the
Scheduled Time are mandatory fields.

Note: Mandatory fields have red text and/or are highlighted in pink. If the time/date
parameters entered in one of the colored fields are entered incorrectly, the field will
remain colored and you will not be able to approve the insertion of the record into the
database.

2. The new flight can be saved as a primary or secondary flight.

3. If you need to create a secondary flight, fill in the mandatory fields to create the new
flight (except the scheduled time field) and select the corresponding primary flight
from the Codeshares drop down list on the right side of the Insert Flight window.

Click OK to approve, or Cancel to abort the task.
7.2.3 Copy/Paste Method

This method allows you to create a new flight by copying an existing flight.

Note: You can use the Copy/Paste method for the Flights, Resources, Desks and
Scheduling views.
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1. Select/Highlight a flight.
2. Click the Copy button or select Edit >Copy.

Click the Paste @ button or select Edit > Paste.
4. The Insert Flight window will open displaying the copied information.

Change the information for the new flight.

New Flight

Carousels Desks Details Comments/Remarks Yisit
General \ Passengers Info | Handlers | Locations (via's) | Belts | Gates

Oper Date 15022005 Codesharing ~
airline 1EE v 1) This is a primary flight
Flight Numeric If you wish to make it a secondary flight
Leg please select its related primary:
Sch Time 15/02/2005 20:20 [ N

Esttime | |

Actual time | ‘

= . r =l v
< >

| OK | | Cancel |
ll | € admin | €8 admin |

Figure 23: insert Flight Window
6. The new flight can be saved as a primary or secondary flight.

If you need to create a secondary flight, fill in the mandatory fields to create the new
flight (except the scheduling time field) and select the corresponding primary flight
from the Codeshares drop down list on the right side of the Insert Flight window.

8. Click OK to approve, or Cancel to abort the task.
7.3 Editing a Flight

The Edit option allows you to edit or add flight related data to a specific flight.

Note: You cannot make changes to the flights data if you are not a privileged user. The
only action allowed for non-privileged users is viewing data using the View option.

7.3.1 Updating a Flight Record

1. Find and select the flight you wish to edit.
2. Use one of the following methods to open the Update Flight window.
B Select Edit & Edit Flight.
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& Right-click on the desired flight and select Edit Flight from the context menu.

& Click the Edit icon on the toolbar.
3. The Update Flight window will open.

. Update Flight 3

D002 arrival
Locations {via's) | Belts | Gates | Carousels
General Passengers Info Handlers
SchTime | 15/02/2005 19:05
Est time [ 15/02/2005 19:05
Actual time
Aircraft Type
Carousel [—v
b
Range I v
Remark [—v
Status [ v:
Mature 5
| OK | | Cancel |
| 2o 8 o

Figure 24: Update Flight Window
4. Update the record with the new flight details (e.g. belt change).

5. Click the OK button to approve or the Cancel button to abort the operation.

If you are updating in grid view and you didn’t choose to use "Auto Save" mode, a
confirmation box will open when you move to the next record asking if you want to save
changes you have made.

Changes to flight details will not appear on displays until after you save the changes.

7.4 Deleting a Flight

The delete option allows you to delete a specific flight record from the database.
To delete a flight record:
1. Open the desired view.
2. Find and select the record you wish to delete.
3. Use any of the following methods to delete the record:
B Select Edit >Delete Flight menu.

& Click the Delete button on the toolbar.
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& Right-click the desired record and select Delete Flight from the context menu.

4. A Delete Flight confirmation box will open.

Delete Flight X]

/@ Youhave chosen to delete flight:
" Dec 20, 2004 TC901 arrival

Do you want to delete this flight from the database?

[ oK || Cancel |

Figure 25: Delete Flight Confirmation
5. Click OK to accept or Cancel to abort the task.

7.5 Linking Flights
7.5.1 Viewing Linked Flights

Linked flights are indicated by a link & symbol in the Info field. If you want to see which
flights are linked together:

1. Right-click the desired flight.

2. Once you have done that, you will be able to see the flight number and the linked
flight number.

3. Click Find Flight (the linked flight) to view the visit flight.

QFO052 arrival < Flight number

& Ssave Ctrl+5

Insert Flight Ctrl+I

(A Edit Flight Ctrl+E

[ view Flight

x Delete Flight Ctrl+D

. Find Flight {secondary) "BA7352" Linked Flight

Find Flight (visit) "QF0S1 D" <+ number

Figure 26: Find Flight
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In the example below, an aircraft arrives as flight QF052 and departs several hours later as

flight QFO5T.

File Edit View Tasks Action: Favorite Tool

& Feb 16, 2005 QF052 arrival

B AR @ B
Desks | Details | Com

Locations (via's) | Bel
General ‘

Passengs
Flights

Scheduling time:
Aircraft type:
Aircraft reqistration:

Oper Date No
1 [1es0z/z00 1@ '
N

stead.
16/02/2005 |4 Oper. Date Carrier

16/02{2005 06:25
43

List Flights

Flight Mo Leg

@ -
3 16/02/2005 BA73S

| 16/02j2005 | QF

v| | oFost

| 0|

Resources

M %4, Feb 16, 2005 QFOSZ arriv

| £ o

{only non linked primary flights are listed)
Scheduling time

16/02/2005 07:50
16/02/2005 14:15

VIA Type Reg.No
SYD 743
SIN 743

2 Hights

[ o

| | Cancel

Figure 27: Linking Flights

To link the flights perform the following:
1. Select the desired arrival flight (flight QF052).

2. Choose Action = Link or click the Link icon on the toolbar.

3. The Link Flights window will open.

: X
& Feb 16, 2005 QF052 arrival
16/02/2005 06:25
743

Scheduling time:
Aircraft type:
Aircraft registration:

Please specify flight to link to:

Y¥ou can only link primary flights.
If vou specify|a secondary Flight its pnrriar';.-' flight will be linked

List Flights

SIN 743

2 Hights

oK | | Cancel

instead.
Oper, Date Carrier Flight Mo Leg
| 16/02j2005 || & v|| oFost  le—FF4—
{onl{PR A flights are listed)
Flt_HNo Sch|PSW < YT Tyme Becr Mo
QF05z 16/ SYD 743

When the List Flights check
box is marked you will be
able to view a list of
available flights

You can type in the
Operational Date and the
Flight Number

List of Carriers

Figure 28: Link Flights Window
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4. You may enter the Linked Flight information by using one of the following methods.

& Enter the associated departure flight information manually (Enter the Flight
Number First).

OR
™  Check v the List Flights check box for a list of available flights.
& Select the flight to be linked.

5. Click the OK button to approve or the Cancel button to abort the linked flight
selection.

6. |If approved the two flights are linked.
7.5.3 Unlinking Flights

To unlink flights perform the following:

1. Select the desired arrival flight (for example flight QFO51).

2. Choose Action = Unlink or click on the Unlink icon on the toolbar.
3. A Confirm Flight Unlink dialog box will open.

4. Click OK to continue or Cancel to abort the task.
7.5.4 Flight Candidate Rules
7.5.4.1 Linking an Arrival flight

The flight being linked must be a Departure flight only.

The dates of the Departure flight must be between the actual Operational Date of the
Arrival flight and up to 4 days beyond in order to cover week ends.

- The Scheduled Departure flight time must be later than the Arrival flight time.

- The chosen Departure flight cannot be linked already.

- The airline code (carrier) must be identical for both the departure and the arrival flights.

- If the aircraft type is specified, the linked flight has to bear the same type as the arrival
flight or have an unspecified aircraft code.

) 3

If the registration number is known, the linked flight has to bear the same registration
number as the arrival flight or have an unspecified registration number.
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7.5.4.2 Linking a Departure flight:

The flight being linked must be an Arrival flight only.

The dates of the Arrival flight must between the actual Operational Date of the
Departure and up to 4 days backwards in order to cover week ends.

- The Scheduled Arrival flight time must be earlier than the Departure flight time.

- The chosen Arrival flight cannot be linked already.

=~ The airline code (carrier) must be identical for both the departure and the arrival flights.

- If the aircraft type is specified, the linked flight has to bear the same type as the
departure flight or have an unspecified aircraft code.

) 3

If the registration number is known, the linked flight has to bear the same registration
number as the departure flight or have an unspecified registration number.
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8.0 Resources

The Resources option allows you to allocate Gates, Belts and Carousels to a specific flight.

8.1 Opening Resources

To gain access to Resources:
1. Click the Resources button on the Task Bar.
2. Select Gates, Belts or Carousels.
Resources
@ Gates Usage
Resources | (&) Belts Usage
W carousels Usage

Figure 29: Opening Resources

3. The selected resource view will open.
8.2 Gates

1. Open the Gates Resource (See above).

2. Once the Gates view opens choose the desired flight(s) using the filter option. You
can view a single gate or all assigned gates.

% Flight Manager- Gates Usage [Today’s Flights] Q@@
File Edit View Tasks Actions Favorites Tools Window Help - & X
B3 20BRRUOXTYS2 e QG

; Scheduling Data | Actual Data
Oper Date Flt No Leg Gate  Sch Start Time Sch Bo.

Flights  [|L_|16/02/2005 QF0S2 |A 2 »|
2 1l6/02/2005 QF0OS1 D ZA '
3 16/02/2005 BA735Z A z
@ 4 1l6/02/2005 QF05S7 D v|
Resources | £ i
=4, Feb 16, 2005 QF0S1 arrival 18 rows
ﬂ.& | I Open Gate || Boarding ” Last Call || Close Gate |

m | £ admin ,_ﬁ admin |

Figure 30: Gates
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8.2.1 Assigning a Gate

This example uses a single gate.

1.

2.

Select/Highlight a row and choose the Scheduling Data tab.

The scheduled gate data can be viewed (Operational Date, Flight Number, Leg, Gate
number, etc.).

Assign a gate to the flight from the available gates (use the drop down list) and
approve your selection.

8.2.2 Changing Gate Status

Click the Open Gate button to open a gate. The current time is

automatically entered in the appropriate field.

Click the Actual Data tab to view the information.

Click the Boarding button to enter the Current Date/Time for the Boarding
time.

Click the Last Call button to enter the Current Date/Time for the Last Call
time.

Click the Close Gate button to enter the Current Date/Time for the gate

closing time.

You can modify the times by clicking the time field you wish to change and typing in the new
time. If the Auto Save mode is not on, you will be prompted to save changes when you move
off the modified field.

|
To view new updates to the database use the Refresh button (see Manual Refresh, Page

29).

8.2.3 Editing/Viewing a Gate

Select/Highlight a Gate record row.

Click the Edit icon or select Edit > Edit Flight.
The Update Flight window will open.
Select the Gates tab.
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%. Update Flight

QFO051 departure

General |  PassengersInfo | Handlers
Desks | Details | Comments/Remarks
Locations (via's) | Belts | Gates | Carousels

Gate 24 i~

Sch Start | 16/02{2005 13:00 |

| 16/02{2005 15:00 |

Sch Final Call | ‘

Sch End | ‘
|
|

v

Sch Boarding

Actual Start I 16/02/2005 13:00

Actual Boarding I 16/02/2005 15:00

I oK || Cancel I

(8 o [ |

Figure 31: Flight Properties - Gate
5. Edit the required fields.

6. Click OK to continue or Cancel to abort the task.
8.3 Belts

To open the Belts view:

1. Click the Resources button.

@

Resources

2. Select Belts Usage.

Resources
Gates Usage
(%) Belts Usage
! Carousels Usage

Figure 32: Opening Belts View

3. The Belts Usage view will open.
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. Flight Manager - Belts Usage [Today’s Flights] @

File Edit View Tasks Actions Favorites Tools Window Help - & X

=B IRARBDERAXT S s EG

; Belt 1 ’ Belt 2
Oper Date Flt No Leg |Belt Name Belt Usage Type Sch Starl

Flights [|L_|16/02/2005|QF052 |A al
2 16/02/2005 QF0OS1 D ‘
3 16/02/2005 BAT735Z A

@ 4 1l6/0Z/2005 QF057 D V‘

< >
Resources e : —

.- {additional information) 18 rows

=" | Belt First Bag " Belt Last Bag I

m | £ admin ,_ﬂ admin |

Figure 33: Belts

4. Choose the desired flight(s) using the filter option. You can view a single belt or all
assigned belts.

8.3.1 Assigning a Belt

This procedure uses s single belt.
1. Select/Highlight a row and choose the Belt 1tab (same for Belt 2).

2. The scheduled Belt data can be viewed (Operational Date, Flight Number, Leg, Belt
number, etc.).

3. Assign a belt to the flight from the available belts (use the drop down list).

4. Approve your selection.

8.3.2 Changing Belt Status

1. Click the Belt First Bag button to set the actual time when the first bag

was put on this belt for the selected flight.
Belt Last Bag

2. Click the Belt Last Bag | | button to set the exact time when the last bag
was put on this belt for the selected flight.

You can modify the times by clicking the time field you wish to change and type in the new
time. If Auto Save mode is not on, you will be prompted to save changes when you move off
the modified field.

|
To view new updates to the database use the Refresh button (see Manual Refresh, page
29).
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8.3.3 Editing/Viewing a Belt

1. Select/Highlight a row

2. Click the Edit icon or select Edit > Edit Flight.
3. The Update Flight window opens.
4. Click the Belts tab.

% Update Flight

QF051 departure
General Passengers Info Handlers
Desks | Details | Comments/Remarks
Locations (via's) A Belts | Gates | Carousels
cok ~
Belt Usage Type { }
Sch Start | 16/02{2005 12:51 |
Sch End | 16/02{2005 13:51 |
Actual Start
Actual End \ ‘ -
| oK I | Cancel |
| o |8 o

Figure 34: Flight Properties - Belts
5. Edit the required fields.

6. Click OK to continue or Cancel to abort the task.
8.4 Carousels

To open the Carousels view:
1. Click the Resources button.

2. Select Carousels Usage.
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Resources
@ Gates Usage
Resources @ Belts Usage
,* Carousels Usage

Figure 35: Opening Carousels View

3. The Carousel Usage view opens.

%% Flight Manager - Carousels Usage [2t] @@
File  Edit View Tasks Actions Favorites Tools  Window  Help - 8 X

>890 RE DEFRX T2 ¢ QW
o <all=> v| [V]A Date » Airline Flight Mo Locations Carousel Reme

|<all> v| @o | | [<al> vl | [<all> v |zall= v | |all> »

O SQL:I

@ Carousel 1 | Carousel 2

Oper Date Flt No Leg Carousel  Priority Sch Start Time Sch End Time Actual Start Time Actual End Time
Resources
04
0s

Flights

Clear

1 1l6/02/2005 QF0S2Z
2 16/0z2/zZ005 QFOS1
3 16/02/2005 QF0OS7
4 16/0z2/2Z005 QFOSS
5 16/02/2Z005 QFOS1
13 1l6/02/2005 QF0ZS
7 16/02/zZ005 QF0ZS
8 16/02/2005 QF0S6

=R - - -

Scheduling
..+ {additional information) 13 rows

l Carousel First Bag " Carousel Last Bag I

[ £ admin [ g admin

Figure 36: Carousels
4. Choose the desired flight(s) using the filter option. You can view a single Carousel or
all assigned Carousels.

8.4.1 Assigning a Carousel

This procedure uses a single Carousel.
1. Select/Highlight a row and click the Carousel 1tab (same for Carousel 2).

2. The scheduled Carousel information can be viewed (Operational Date, Flight Number,
Leg, Carousel, etc.).

3. Assign a Carousel to the flight from the available Carousels (use the drop down list)
and approve your selection.

8.4.2 Changing Carousel Status

1. Click the Carousel First Bag | Carousel First Bag | button to set the actual time when the

first bag was put on the carousel for a selected flight.

2. Click the Carousel Last Bag | otz il | button to set the exact time when the

last bag was put on the carousel for a selected flight.
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You can modify the times by clicking the time field you wish to change and entering the new
time. If the Auto Save mode is not on, you will be prompted to save changes when you move

off the modified field.

|
To view new updates to the database use the Refresh button (see Manual Refresh page

29).

8.4.3

Editing/Viewing a Carousel

1. Select/Highlight a row

2. Click the Edit icon or select Edit > Edit Flight.

The Update Flight window opens.

Click the Carousels tab.

% Update Flight

QFO051 departure

General
Details

Passengers Info
Comments/Remarks

Locations (via's) | Belts | Gates | Carousels ]Desks

Handlers

Carousel 0S v
Priority [ ]
Schstart | 16/02/2005 16:00 |

Sch End | 16/02{2005 18:00 |

16/02/2005 16:00

Actual End \ |

Actual Start

|£ admin@ admin|

Figure 37: Flight Properties - Carousels

5. Edit the required fields.

6. Click OK to continue or Cancel to abort the task.
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9.0 Desks

9.1 Opening the Desks View

To open the Desks view:

I
1. Click the Desks Leess | button on the Task Bar or Select Tasks >Desks Allocations.

2. The Desks view will open.

3. Use the Filter option to view the required desk allocations.

%% Flight Manager- Desks [ Flights]

File  Edit View  Tasks Actions Favorites Tools  Window  Help

"B S RBRE DFRX T% ¢

A General
Desk Mame Oper Date Handler Sch Open Sch Close

Flights 1 s 10/0z/z20085 QF 10/0z/2005 16:58 10/0Z/2005 17:58
2 |8 10/02/2005 QF 10/02/2005 16:58 10/02/2005 17:58

3 7 17/02/z2005 QF 17/02/2005 15:53 17/02/2005 16:53
@ 4 6 09/02/2005 W 09/02/2005 17:51 09/02/2005 19:11 !
Resources < >

ad | I I |

| | & admin | €8 admin |

Figure 38: Desk Allocation Window
9.2 Desk Details

To view desk details:

1. Select a desk.

2. Click the Desk Details button.

The desk details window will open on the right side of the window.

4. When navigating to other desks using the general tab, the Desk Details will change
accordingly.

General Desk 8 details Q%
Desk Name = Oper Date Han Flights
1 5 10/0z2/2005 QF A Flight Na Leg Operational Date
2 8 09/02/2005 2Q D 09/02/2008
3 8 aF Classes
4 1z 09/02/2005 W # Carrier Description Text
5 € 09/02/2005 ww 1 QF Business Class Business (
6 & 09/02/2005 W < >
7 s 09/0z/2005 T Carriers
8 |4 03/02/2005 ww Carrier  Description
9 4 07/0z2/20058 67 QF Qantas Airways
0 1 07/02/2005 20 |V
< = | nsertFlight || Delete Fiight

Figure 39: Desk Details
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9.3

systems

Assigning a Flight, Class or Carrier to a Desk

Use the following procedure to assign a Flight to a desk. Assign a Class or Carrier to the
specified flight using the same procedure for a flight assignment. The only difference
between the procedures is that Class and Carrier can be typed directly into the grid.

If you wish to assign a new flight to the specified desk:

1. Ensure the Desk Details window is Open. Refer to Desk Details on page 53.

General Desk 8 details &%
Desk Name = Oper Date Han Flights
1 5 10/0z2/2005 QF A Flight Na Leg Operational Date
2 8 09/02/2005 2Q D 09/02/2008
3 |8 QF Classes
4 12 03/02/2005 WW # | Carrier | Description Text
5 & 09/02/2005 ww 1 QF Business Class Business (
[3 & 09/02/2005 wmr < >
7 |5 09/02/2008 U Carriers
8 4 03/0z/2005 WW Carrier Description
9 4 07/02/2005 67 QF Qantas Airways
10 1 0770272005 2D |V
< = | nsertFlight || Delete Fiight

Figure 40: Desk Details

2. Select a desk allocation under the General tab.

3. Select a flight row under Desk Details.

4. Click the Insert Flight oz il button.

The Unassigned Flights window will open.

. Unassigned Flights X]

Flight No Leg Operational Date
1 QF025 D 09/02/2005 ~
2 QF026 D 09/02/2005
3 QF052 D 09/02/2005
4  QF0SS D 09/02/2005 v
OK I | Cancel

Figure 41: Unassigned Flights

6. Select the desired flight from the Unassigned Flights list.

7. Click OK to approve or Cancel to abort the action.
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To allocate new desk(s):

1. Ensure the Desks View is open. Refer to Opening the Desks View on page 53.

- Flight Manager - Desks [ Flights] @@@
g X

Edit  View  Tasks Actions Favorites Tools Window  Help o

-8 S0 BE DFRX T% 7¢

f General
Desk Name  Oper Date Handler | Sch Open Sch Close
Flights 1 5 10702720085 QF 10/02/2005 16:58 10/02/2008
2 8 10/0z/20085 QF 10/02/z005 16:58 10/02/Z00S
3 7 17/0z/z008 QF 17/02/z005 15:53 17/02/Z00S
@ 4 3 0370272005 wmr 09/02/2005 17:51 09/02/2008
Resources <l
SR

> | | I I |

17:58
17:88 1
16:53
19:11(3
2

4 rows

I g admin | & admin I

Figure 42: Desks Window

2. Select Edit 2 Insert or click the Insert icon on the toolbar.

3. The Desk Allocation Window will open.

. Desk #Allocation @

p New Desk Allocation

Desks
0ot fad
002z
004

<<
=]

Operational Date

14APR2006

Handler Code Carrier Check to synchronize
Lo,p, b ‘ Lqp, b Handler versus Carrier

Scheduled Open Time Scheduled Close Time
| 14APR2006 10:00 | \

Actual Open Time

Actual Close Time

| \

Text

{ \

Flight
| An3z8 | [0 14aPrz006 | [ mnsertFight |

Class number
[ H ‘ | Insert Class |

| | & adwin | €8 admin |

Figure 43: Desk Allocation
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4. Select the desk(s) to allocate:
a. Click a desired desk on the left and then click the Select IL' button to
move it to the Allocation area on the right.
b. To remove a flight from the Allocation area, click the flight and then click the
Deselect IL' button.

5. Select the Carrier and Handler Code from the drop down lists.

6. Enter the Scheduled Open Time and Scheduled Close Time.
Add textual remarks if required.

Insert Flight

8. Click the Insert Flight button.
A list of available flights will open.
10. Choose the desired flight.
1. Click the Insert Class w button and choose a class from the list of available

classes.

12. Click OK to approve or Cancel to abort the action.

9.5 Editing a Desk Allocation

1. Ensure the Desk View is open. Refer to Opening the Desks View on page 53.
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File  Edit View Tasks Actions Favorites Tools  Window  Help o
-8B BB REFRX T%2 7 QK
q General
Desk Name Oper Date Handler Sch Open Sch Close
Flights 1 5 1l0/0z/2005 QF 1l0/0z/2005 16:58 10/0Z/2005 17:58
2 8 1l0/0z2/2005 QF 1l0/02/2005 16:58 10/0Z2/2005 17:58 !
3 7 17/0z/2005 QF 17/0z/2005 15:53 17/0Z/2005 16:53
@ 4 3 08/0z/2005 ww 09/02/2005 17:51 09/02/2005 19:11 !
Resources < >
M 4 rows
> | [(E=s | = |
| | & admin | €8 admin |
—

Figure 44: Desks Window

2. Select the desired desk.
3. Use one of the following methods to open the Desk Allocation window.
& Select Edit > Edit.
& Right-click the desired flight and select Edit Desk from the context menu.
& Click the Edit icon on the toolbar.
4. The Desk Allocation window will open.
. Desk Allocation
Desk Operational Date
a02] v | 2s8PR2007
Handler Code Carrier Check to synchronize
bA v ‘ P"' v ] Handler versus Carrier
Scheduled Open Time Scheduled Close Time
| 25APR2007 16:31 | | 25APR2007 17:31 |
Actual Open Time Actual Close Time
| 25APR2007 17:04 | \ |
Text
Flight
[ BA1502 ] [ D 25APR2007 [ | Insert Flight |
Class number
\ E ‘ \ Self-Service Check-in ’ Insert Class |
I QK | | Cancel |
Il |£ sust @ SUSR |

Figure 45: Editing a Desk Allocation

5. Edit the desired fields.
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6. Click OK to approve or Cancel to abort the action.

|
To view new updates to the database use the Refresh button (see Manual Refresh page
29).

9.5.1 Editing a Desk Name
A desk name can be edited using the Editing a Desk Allocation procedure. This dramatically
simplifies Desk re-allocation.

Instead of creating new desk allocation records by copying desks and removing old desk
allocation records you can simply change the desk name. All desk details including flights,
carriers and classes information is preserved. The desk name is editable both in the "Desks”
Grid View and in the Desk Allocation window.

9.6 Viewing a Desk Allocation

1. Ensure the Desk View is open. Refer to Opening the Desks View on page 53.

. Flight Manager- Desks [ Flights] @@@
g X

File  Edit View Tasks Actions Favorites Tools  Window  Help o

-8 S BR DEFRX T2 ¢ Q0

General

4
* Desk Name Oper Date Handler Sch Open Sch Close
Flights 1 5 10/0z/2005 QF 100272005 16:58 1070272005 17:58
2 8 1l0/0z/2005 QF 1070272005 16:58 1070272005 17:58
3 ? 17/0z/2005 QF 17/02/z005 15:853 1770272005 16:53
@ 4 3 09/0z/2005 W 08/02/2005 17:51 08/02/2005 19:11
Resources < >
% 4 rows

- | I I |
| | & admin | g admin |

Figure 46: Desks Window
2. Select/Highlight the desired row/desk.
3. Use one of the following methods to open the Desk Allocation window.
»  Select Edit > View.

& Right-click on the desired flight and select View from the context menu.

&  Click the View @ icon on the toolbar.

4. The Desk Allocation properties window will open.
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%. Desk Allocation

@ Desk A02

!

Operational Date

Desk
02| v| [ 258PR2007
Handler Code Carrier Check to synchroni
ynchronize
BA v] BA v Handler versus Carrier

Scheduled Close Time
l 25APR2007 17:31
Actual Close Time

Scheduled Open Time
25APR2007 16:31 J
Actual Open Time

‘ 25APR2007 17:04

[

Text
|
Flight
H[‘ 258PR2007 ‘ Insert Flight
Class number
‘ l Self-Service Check-in ‘ Insert Class

| BA1S02

[E

| & susr | €8 SUsR |
-

Figure 47: Desk Allocation Properties

5. Click Cancel to close the window.
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10.0 Scheduling

10.1 Opening the Primary Flights View

To gain access to Primary Flight Scheduling:

1. Click the Scheduling [sheding] button located on the task bar.

2. Select Primary Flights Scheduling.

—~—{(] Scheduling
1] Primary Flights Scheduling

Scheduling | 14| Codeshares Scheduling
A Wisits Scheduling
“ Desks Scheduling

Figure 48: Opening Primary Flight Scheduling
3. Select a filter.

4. The flights list will open.

% InterSystems Flight Manager - Primary Flights Scheduling [CurrentSeason] g@@
g X

File  Edit View Tasks Actions Favorites Tools Window  Help o

-8 AL BRB RDEFRX T2 ¢ QG

A Airline Flight Mo Valid Dates »>  Weekdays Exclude S
| J vl
’j VD |<al> v I | <all> vzl
O squ l

@ General |Handlers Locations {via's) | Belts | Gates | Carousels | Details | Yisits
Flt No Leg Info Weekdays Valid From Date Valid To Date Season Name  Exclude Locatic

Resources
1 CX995 A 1234567 26/03/2006 31/10/z006 S06 HLZ A‘
2 CX996 A 1234567 26/03/2006 31/10/2006 S06 HOF 1
3 CX997 A 1234567 26/03/2006 31/10/z006 S06 HOB
4 AZ765 A ¢hootiooo 26/03/2006 31/10/2006 S06 N ABC V‘
sl 2
.-+ {additional information) 1442 rows
| [ [ validate Al |

| | & admin |g admin |

Figure 49: Primary Flight Scheduling
10.2 Scheduling a New Flight

1. Use one of the following methods to insert a new scheduled flight:
B Select Edit & Insert.

& Click the Insert icon on the toolbar.
Right-click on the screen and select Insert from the context menu.
Use the keyboard CTRL+I.
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2. The Insert Flight window will open.

% Insert Flight

New Flight

| Belts | Gates | Carousels [ Details | visits
General ] Handlers || Locations (via's)
Aitline Flight Mumeric Leq Sch Arr Dep Time
Yalid From Date Yalid To Date Weekdays Season
I | | | v
Exclude ] I

Cancel

I Iﬁ admin Ef admin |

Figure 50: Insert Flight Window

3. Enter the necessary information. Required parameters are highlighted in pink.

4. Click OK to approve or Cancel to abort the action.
10.3 Validation

Collisions between scheduled flights are possible. Validation allows you to find scheduling
conflicts. The following criteria are used to find flight collisions:

- Both flights have the same carrier, flight number, leg, season & weekdays.
- Valid date ranges for the flights overlap.

n Both flights are "excluded".
) 3

The valid date range for one (or both) of the flights does not fall within the valid dates
for the season.

Two validation options are available: Single Flight and All Flights.
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10.3.1 Validating a Single Flight

To validate a flight perform the following steps:

1. Select the desired flight.

2. Click the Validate button to check for possible collisions.

3. If the flight is valid, | v/ no conflicts | and L¥alidation results: 0 conflicts. | messages will appear in
the Info Bar.

4. If the flight has potential collisions the following information is displayed on the
Info Bar:

a  flight number
»  effective scheduled dates

m  |ist off potential collisions

Flight QF020 arrival [31/10/2004 - 26/03/2005 .2.....] - potential collisionsFix Collisions = ¥ A X

Flight Number = Leg Valid From Date  Valid To Date = Weekdays Exclud Season

1 QF0Zz0 A 31/10/2004 2670372005 .2..... wo4 ~
2 QF0z0 A 0Z/11/2004 O0l/0Z/20058 .Z2..... wo4
3 QF0z0 A 02/11/2004 0170272005 .2..... wo4 v

Figure 51: Potential Collisions Information
10.3.2 Validating All Flights

The Validate All option allows you to validate the entire list of scheduled flights according to
your filter definitions. To validate the entire list of flights perform the following steps:

1. Click the Validate All L_Yaidate Al |\ vion.

2. The validation process will begin.

3. When the validation process ends, you will see the validation results in the Valid field.
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Exclamation mark -

potential collisions

No collisions

Figure 52: Collision Marks

To view a list of collisions for a specific flight, perform the steps described in Validating a
Single Flight on page 62.

The scheduled flight list can contain thousands of records. Because of this, the Validate All
procedure can last a long time. The following functions are available while executing the
Validate All option:

- l FELEE i I— Stop the validation. Any records already validated will be displayed

under the Valid field label.

| N | - Resume the validation procedure from the point it paused.

h Cancel Validate All| . c5ncel the validation. Restarting Validate All will begin at the first
record.

10.3.3 Hiding/Re-displaying Validation Results
After the validation procedure is finished you can hide the validation results. This is done by
hiding the column.
To hide validation results:
- Right-click the validation column and choose the Hide Column option.
To redisplay validation results:

- Validate a single flight or all flights.

10.4 Editing a Primary Flight

1. Ensure that the Primary Flight view is open. Refer to Opening the Primary Flights
View page 60.

2. Select a flight and click the Edit icon or select Edit > Edit.

3. The Schedule Flight Properties window will open.
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QF1001 departure
| _Belts | Gates | Carousels | Details | visits

General ] Handlers Locations {via's)

Leg

Exclude

=

Sch Arr Dep Time | 20:00
Aircraft Type
Location
Location 2
Location 3
Range
Mature

Yalid From Date | 02NOY2007
Yalid To Date 26]AN2008
Weekdays ) -

| & admin Ig admin |

Figure 53: Schedule Flight Properties Window
4. Click the tabs to edit the information.
General - general flight data (Weekdays, Valid days of operation).
Handler - the specific handler of the scheduled flight.
Locations - via’s of the scheduled flight.
Belts - belts assigned to the scheduled flight.
Gates - gates assigned to the scheduled flight.

Carousels - carousels assigned to the scheduled flight.

vy vy vv.y

Details - additional data like terminal names and ground power.

5. Click OK to approve or Cancel to abort the action.

10.5 Viewing a Primary Flight

1. Ensure that the Primary Flight view is open. Refer to Opening the Primary Flights
View page 60.

2. Select/Highlight a flight and click the View @ icon.
3. The Schedule Flight Properties window will open.
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. Update Flight X

BAS555 departure

Belts Gates | Carousels | Details | visits
General ] Handlers “ Locations (via's)

N

Sch Arr Dep Time

Aircraft Type

Location

Location 2 KK v

Location 3

Mature

Yalid From Date | 18MAY2007
Yalid To Date 300CT2007
Weekdays 1234567

| & admin | & admin |

Figure 54: Schedule Flight Properties Window
4. Click the tabs to view the information.
General - general flight data (Leg, Valid days of operation).
Handler - the specific handler of the scheduled flight.
Locations - via’s of the scheduled flight.
Belts - belts assigned to the scheduled flight.
Gates - gates assigned to the scheduled flight.

Carousels - carousels assigned to the scheduled flight.

vy vy vv.y

Details - additional data like terminal names and ground power.

5. Click Cancel to close the window.
10.6 Codeshares Flights
10.6.1 Opening the Codeshares Flight View

To gain access to Codeshares Flight Scheduling:
1. Click the Scheduling button located on the task bar.

2. Choose Codeshares Scheduling.
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3. Select a filter.

Scheduling

Scheduling

}£ Primary Flights Scheduling
17l Codeshares Scheduling
A" Wisits Scheduling
“ Desks Scheduling

Figure 55: Code Share Selection

4. The Codeshares Scheduling view will open.

%% InterSystems Flight Manager - Codeshares Scheduling [default]

File  Edit

View  Tasks

Actions

Favorites  Tools

i>-8 90 BRB DEFRX T%

Window  Help

EEX

- 8

g ¢ Qg

A Primary Flight Aitline Primary Flight Mo Valid Dates »>

.

x

D |<all> v‘ | l
O squ ‘

General

PSS Flt Number Leg Weekdays Sec Flt No Valid From Date Valid To Date
1 QF10 D ...45.. 07/03/2005 12/03/2005 A
2 QFlsz A 1234567 BA7354 17/1z/2000 30/03/z002 =
3 QF0S1 A . S BA7351 3170372002 zz/flo/zooz
4 NF0z0 A 50030 QF378 31/10/1999 2670372000 ~
5 CXloz A ...4..7 CX1l03 z7/10/2002 2870372003 !
3 JL76Z D 1234567 QF363 3171071999 2670372000
2 PX00S D P T | QF35z 0l/09/2002 28/03/2003
8 £Q235 kS |ssoo00 7 LHE382Z 3171071999 26/03/2000
9 FI2z0 D .234567 QF337 2641072003 2870372004 !
10 MH134 D ...456. KL4zze 1171272003 27/03/2004 :v‘

< >
DB Table 877 rows
v
| | & admin | €8 admin |
—_—

Figure 56: Codeshare View

10.6.2 Scheduling a New Codeshare Flight

To add a new Codeshares flight:

1. Ensure that the Codeshares Flight view is open. Refer to Opening the Codeshares
Flight View page 65.

2. Use one of the following methods to open the Insert Codeshare flight window.
B Select Edit & Insert.

&  Click the Insert icon on the toolbar.
& Use the keyboard CTRL+I.

3. The Insert Codeshare Flight window will open.
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(L
New Codeshare Flight
Prmry Airline Prmry Flt Numeric Leg
| v | v
Valid From Date Valid To Date Weekdays
Sec 1 Airline v
Sec 1 Flt Numeric
SeclVial v
SeclVia2 v
Sec1Via3 v
Sec1Via4 v
Sec1ViaS v
| & admin | € admin |

Figure 57: Insert Codeshare Flight Window

4. Enter the necessary information. Required information is highlighted in pink and/or
has red titles, e.g. Primary Airline, Primary Flight Number, etc.

5. Click OK to approve or Cancel to abort the action.

10.6.3 Editing/Viewing a Codeshares Flight

1. Ensure that the Codeshares Flight view is open. Refer to Opening the Codeshares
Flight View page 65.

2. Select/Highlight a row and click the Edit or View @ icon.
Change/View the desired fields.
4. Click OK to approve or Cancel to abort the action.
10.7 Viewing Visits Scheduling

Visits Scheduling is a read only view, which displays additional information about the primary
flights scheduling views (bays, terminals, overnight stops, etc.).
To gain access to the Visits Scheduling option:

1. Click the Scheduling button located on the task bar.

2. Choose Visits Scheduling.
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—~ (1)

=

Scheduling

Scheduling
_}£ Primary Flights Scheduling
}# Codeshares Scheduling
&* Visits Scheduling
& Desks Scheduling

Figure 58: Visits Scheduling Selection

3. Select afilter.

4. The Visits Scheduling view will open.

File — Edit  WView  Tasks

=8 8l

Flights O squ

Resources | 1

Scheduling

DB Table

S

I Flight No Valid Dates >>
@ General
Arr Yalid From Date

01/1lz/2004
2 0z/lz/z004

%. InterSystems Flight Manager - Visits Scheduling [itamir] Q@@
Actions  Favorites  Tools  Window  Help - 8 X
BRE DERX T4 /¢ QG
) Exclude ‘Weekdays Bay

o o
Arr Valid To Date Arr Weekdays Arr Exclude I

10/01/z008 1234567 1
11/01/z2005 1234567 1 2
bd
Z rows

| & admin | € admin |
=

Figure 59: Visits Scheduling Window

5. All toolbar copy, insert, edit, and delete options are grayed out to indicate these

operations are not allowed.
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10.8 Flight Load

Flight load related tasks are enabled on the Action menu when the Primary Flights
Scheduling window is active.

Ac‘lionsl Favorites Tools  Window H

Validate All
Load Flights From Schedule
Configure Flight Load

L
&

Figure 60: Flight Load Menu

10.8.1 Running Flight Load

To perform a flight load, click on the Load Flights From Schedule menu. The following dialog
will open. Required information, From Date and To Date, is highlighted in pink and has red
titles. Once these two fields are filled in, the Start button will be enabled. The following is a
brief description of the fields on this dialog:

From Date: The beginning date range of flights to load, e.g., TODAY
To Date: The ending date range of flights to load, e.g., TODAY + 1

Season: The schedule season to load flights from, e,g,, W11. If not specified,
default season is used.

Airline: The airline to load flights. If not specified, all airlines that are handled
by the current user will be loaded.

Flight No: A specific flight to load, e.g., AA1234.

Delay: The number of seconds to pause between each flight when loading
them from the schedule.
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Flight Load ﬂ
Load Flights From Schedule

From Date

To Date

Season ; v
Arine | -
FightNo |

Delay

Start Stop
I & admin I—Q admin |

Figure 61: Flight Load Dialog

10.8.2 Configuring Flight Load for the Server

If flight load is configured to run regularly on the server, it is possible to change the
configuration using Flight Manager. To view or to change the current configuration on the
server, click on Configure Flight Load from the Action menu. The following dialog will open.
There are two sets of fields for configuring flight load. The first set of fields is the same as
those in the Flight Load dialog, explained in the previous section. The second set of fields
configures the “cron” job that runs Flight Load on the server. The following is a brief
description of the fields:

Minute: The minute of the hour to run flight load, valid values are O to 59.
Hour: The hour of the day to run flight load, valid values are O to 23.

Day of Month: The day of month to run flight load, valid values are 1 to 31, and *.
Use * to specify every day of the month.

Month: The month to run flight load, valid values are 1 to 12, and *. Use * to
specify every month of the year.

Day Of Week: The day of the week to run flight load, valid values are O to 6, with
Sunday = 0O, and *. Use * to specify every day of the week.
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r ~
Configure Flight Load @

Flight Load Cron Job
-Flight Load Options-
FromDate today+1 v
To Date today+1 v
Season v
Airline v
Delay
~Cron Job Options
Minute 0 v
Hour 3 v
Day Of Month * v
Month * v
Day Of Week * v
| Submit H Close l
| & admin [_Q admin |
[ Pl

Figure 62: Configure Flight Load

10.9 Desks Scheduling
10.9.1 Opening the Desks Scheduling View

To gain access to Desks Scheduling:
1. Click the Scheduling button located on the task bar.
2. Choose Desks Scheduling.
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i Scheduling 3
}# Primary Flights Scheduling |

Scheduling | 14| Codeshares Scheduling
A* Wisits Scheduling
“ Desks Scheduling

Figure 63: Desks Scheduling Selection
3. Select afilter.
4. The Desks Scheduling view will open.

% InterSystems Flight Manager - Desks Scheduling [Sch Desks] Q@@
File  Edit  View Tasks Actions Favorites Tools  Window  Help - 8 X

=8 3L BB DAOX TS 7

A Date »> Desk Handler Carrier
O | <al> v | [<all> | [<all> v

@ General |

Desk Mame Valid From Date Valid To Date Weekdays Sch Open Time Sch Close Time Handler E
Resources || 1 1lblb 07MARZOO7? 30AUGZ0O07 1234567 05:45 09:00 Ua N A~ |
2 1bd Z6JANZ007 01MARZOO7 1234567 10:00 11:00 LY N Fl

3 558 Z27JANZ007 01MARZOO7 .23456. 10:00 11:00 LY N

4 1blb 07MARZOO7 01lAPRZOO7? 1234567 09:00 10:00 AC N

5 1lblb 07MARZOO7? 01lAPRZOO7? 1234567 10:00 11:00 LY N

3 1lblb 09MARZOOD? 16MARZOD? .. ... &7 09:00 10:00 AC Y

7 lblb Z1MARZ007 Z1MARZOO7 FC SR 09:00 10:00 AC T

g 1blb Z3MARZOO7 30AUGZO0O? .. ... &7 05:45 17:00 AC Y

9 1lblb Z6JANZ007 01MARZOO? 1234567 0%:00 10:00 LY N
= o 17 0ZDECZ003 03JANZ00D4 1234567 1Z:30 16:30 EIN v|

= < >
DB Table 30 rows

| Desk Details |
| | £ admin rﬁ admin |

Figure 64: Desks Scheduling View

10.9.2 Scheduling a New Desk Allocation

To schedule a new Desk Allocation:

1. Ensure that the Desks Scheduling view is open. Refer to Opening the Desks
Scheduling View page 71.

2. Use one of the following methods to open the New Desk Allocation window.
& Select Edit & Insert.

&  Click the Insert icon on the toolbar.
& Use the keyboard CTRL+I.
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3. The New Desk Allocation window will open.

%. Scheduled Desk Allocation ‘z]

A -
New Desk Allocation
 Desks
1 |
1bib |
1bd
:
3
"
S v |
__Handler Code Carrier Check to synchronize
v | 2| Handler versus Carrier
Walid From ) Valid To

Scheduled Open Time Scheduled Close Time

‘Weekdays Season Exclude Text
v
Flight
Class number :
| | & admin | €8 admin |

Figure 65: New Desk Allocation Window
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4. Enter the necessary information. Required information is highlighted in pink and/or
has red titles, e.g. Handler Code, Valid From, etc.

5. Click OK to approve or Cancel to abort the action.

10.9.3 Editing/Viewing a Scheduled Desk Allocation

1. Ensure that the Desks Scheduling view is open. Refer to Opening the Desks
Scheduling View page 71.

2. Select/Highlight a row and click the Edit or View @ icon.
3. Change/View the desired fields.

4. Click OK to approve or Cancel to abort the action.
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10.9.4 Deleting a Scheduled Desk Allocation

1.  Ensure that the Desks Scheduling view is open. Refer to Opening the Desks
Scheduling View page 71.

2. Select/Highlight a row.
Use one of the following methods to delete the desk allocation.
e Select Edit 2 Delete.

e Click the Delete x icon on the toolbar.
e Use the keyboard CTRL+D.

4. Click Yes to approve or No to abort the action.
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11.0 DB Table

The DB Table Option allows you to manage selected database tables (AIRLINES, HANDLERS,
etc.). Access to this option is controlled by user permissions. The following procedures are
examples only. You may or may not have access to the same tables shown. The procedures
that follow are the same for all database tables.

11.1 Opening DB Tables

1. Click the DB Table button on the Task Bar or Select Tasks - DB Table.
2. The “Open System View” window displays.

Select from one of the available views below

ER=06 Tabe |

= admin
Handlers
Airlines
Handler Access
= default

Aitline Messages
Podium Signs

Figure 66: DB Table Screen
3. Select the database table you wish to edit.

4. Click OK to open the desired view.
In this example we will open the Airlines table view.

5. The selected table opens to permit editing/viewing.
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%. InterSystems Flight Manager - Airlines [default] g@@
- 8 X

File ~ Edit View Tasks Actions Favorites Tools ‘Window  Help
=8 S BB RHDX T2 77 QU@
gl z
Flights |
Airlines
@ Code Ak CarrierNum  Description Handler = HanRamp  HanBaggage  HanCargo  Han Engineering
1 EBRT EBRITISH REGIONAL AIR A‘
Resources |2  EFS EUROPE FALCON
3 INR INTER AIR AB
ﬁ 4 AEL AIR EUROPE ITALY
s GBJ
Desks 6 INV
7 e
s VDA
9 AEN
Scheduling 10 VET Virgin Express
11 DKE
- B v
# < bd
DB Table 785 rows
| & advin | € admin |

Figure 67: Opening a DB Table

1.2 Editing Records
1. Find the desired record. You may use the Query Panel/Query Wizard if needed.
2. Select the record.
3. Edit the Record using one of the following methods:
& Change the information directly in the grid view.
& Click the Edit Details button, then update the desired information.
4. If the Auto Save mode is not on, you will be prompted to save your changes.
11.3 Inserting a Record
1. Open the DB table.
2. Select Edit & Insert or click the Insert button.
3. The Insert Data screen opens.
4. Enter the needed information.
5. Click OK to approve or Cancel to abort the action.
11.4 Deleting a Record
1. Find the desired record. You may use the Query Panel/Query Wizard if needed.
2. Select the record.
Select Edit > Delete or click the Delete button.
4. A Confirm Delete dialog box will open.

Click OK to approve or Cancel to abort the action.
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11.5 Viewing a Record

1. Find the desired record. You may use the Query Panel/Query Wizard if needed.

2. Select the record.

Select Edit > View or click the View @ button.
4. You will not be allowed to make any changes to the record.

Close the window when you are finished.
11.6 Filters

You may use filters to assist you with these tables. Refer to the Using Filters on page 79 for
more information.
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12.0 Other Functionality

12.1 Auto Save

When typing directly into a row with the Auto Save option On, data is automatically saved
into the database when moving to the next row. If the Auto Save option is Off you will be
asked to confirm the update.

To turn Auto Save mode ON or OFF, select Edit > Auto Save from the menu.
A checkmark ¥'indicates that Auto Save is ON.

12.2 Sorting Data

To sort the information in a table click any of the column headings. The data is sorted
alphabetically using the column selected. Sorting a column can be done from A to Z or Z to A.
Click the heading multiple times to switch between to two sorting types.

. Flight Manager - Belts Usage [Today’s Flights] E]@@
File Edit View Tasks Actions Favorites Tools Window Help - & X

> BEIARBRDFRXT S s TEG

v

Belt 1 | gelt 2
4
( Oper Date Flt No Leg |Belt Name Belt Usage Type Sch Starl >
Fllghts 1 16 /02720057 JFOSZ A :I
2 160272005 QFOS1 D !
3 16/02/2005 BA735Z A
@ 4 16/02/2005 QF0S7? D VI
< >
Resources - : : B o
.-+ {additional information) 18 rows
== | | Belt First Bag " Belt Last Bag I

m | £ admin I_ﬂ admin |

Figure 68: Sorting Data

12.3 Un-sorting Data

To un-sort information, select View > Unsorted.
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13.0 Using Filters

The Filter option allows you to view flights and flight related data (such as resources, desks or
scheduling) based upon your preferences. A Filter is an SQL based statement saved with a
specific name. A filter can have dynamic parameters with defined values to request
information when used.

You can Create, Edit or Delete a filter in the different views.
13.1 Opening the Filters Window

1. Use one of the following methods to open the filters window.
&  Choose View >Filters.

& Click the Filters icon on the toolbar.
& Use the keyboard CTRL+R.

2. The filters window will open.

. Database Filters - FLTO_VIEW X

File  Edit Help
DX KX @
& ©Group: admin v £ Ousen
Name Description
3 mySAT_flights ~
4 SAT FLTU SAT
5 SAT-Saitlines
& SAT-QF-TG For YISITS linkfunlink test
7 SAT_AIRLINES SAT FILTER
8 Today Flights Today flights
9 Today's Flights
10 TodayArr Today Arrival flights
11 TodayDep Today Departure flights
12 TodayDep EI Today EI departures
13 Tomorrow Tomorrow flights o
| LEG = 'A' and OPER _DATE = today | & admin | €8 admin |
=

Figure 69: Database Filters
13.2 Selecting a Filter

To select a preexisting filter:
1. Open the Filters Window (See Opening the Filters Window above).
2. Select a filter.

3. Click OK to apply the filter or Cancel to abort the action.
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13.3 Creating a New Filter

This procedure creates a new filter, gives it a name and assigns it to a view. Adding the actual
filtering to be performed is accomplished in the section Defining SQL for a Filter on page 83.

1.  Open the Filters Window (See Opening the Filters Window on page 79).

3. Database Filters - FLTO_VIEW 3]

File  Edit Help

DX X O
& @ Group: admin v £ Ousen
Name / Description

3 mySAT_flights ~

4 SAT FLTU SAT

5 SAT-Sairlines

& SAT-QF-TG For YISITS linkfunlink test

7 SAT_AIRLINES SAT FILTER

8 Today Flights Today flights

9 Today's Flights

10 TodayArr Today Arrival flights

11 TodayDep Today Departure flights

12 TodayDep EI Today EI departures

13 Tomorrow Tomorrow flights v

s wiard
| LEG = 'A' and OPER _DATE = today | & admin | €8 admin |
=

Figure 70: Database Filters
2. Use one of the following methods to open a New Filter window.
a. Select Edit > New Filter.

b. Click the New Filter icon on the toolbar.
c. Keyboard CTRL+N.

3. The New Filter Properties window will open.

. Filter Properties @

Name T
Description | |
Filter | ROW_ID 15 NULL ]
Yiew Name FLTO_VIEW v|
Security Group fadmin v
Solution RAIMS v
Application FLTU v
User Name | v]
| Insert mode | & admin | £ adnin [

Figure 71: Filter Properties Window
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4. Enter the information for your new filter using the text boxes and dropdown lists.

a. Required fields have red titles.

b. Default values for View Name, Security Group, Solution, and Application are
supplied but may be changed.

5. Click OK to approve or Cancel to abort the action.

13.4 Editing a Filter

1.  Open the Filters Window (See Opening the Filters Window on page 79).

% Database Filters - FLTO_VIEW 3]

File  Edit Help

‘D X A

Name
3 mySAT_flights
4 SAT

5 SAT-Sairlines

6 SAT-QF-TG

7 SAT_AIRLINES
8 Today Flights
9 Today's Flights
10 TodayArr

11 TodayDep

12 TodayDep EI
13 Tomorrow

SQL Wizard

& © Group:

e @

admin

v £ Ousern

Description
FLTU SAT

For YISITS linkfunlink test
SAT FILTER
Today flights

Today Arrival flights
Today Departure flights
Today EI departures

Tomorrow flights =

| LEG ="A" and OPER_DATE = today

| & admin |g admin |

Figure 72: Database Filters

2. Select the desired filter.

3. Use one of the following methods to Edit the selected filter.

& Select Edit > Edit Filter.

&  Click the Edit Filter Qf icon on the toolbar.

& Use the Keyboard, CTRL+E.

4. The Filter Properties window will open.
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. Filter Properties @

Name =]
Description | |
Filter | 06-01-01', ¥YYY-MM-dd) |
Yiew Name FLTO_VIEW v|
Security Group fadmin v
Solution RAIMS v
Application FLTU v
User Name | v]
| Update mode | & admin | £ adnin [

Figure 73: Editing A Filter

5. Edit the desired fields.

6. Click Insert to approve or Cancel to abort the action.

13.5

Deleting a Filter

1.  Open the Filters Window (See Opening the Filters Window on page 79).

3. Database Filters - FLTO_VIEW 3]

File  Edit Help

DX X O
& @ Group: admin v £ Ousen
Name / Description
mySAT_flights ~
SAT FLTU SAT

3

4

5 SAT-Sairlines

& SAT-QF-TG For YISITS linkfunlink test
7 SAT FILTER

g

9

Today flights

SAT_AIRLINES
Today Flights
Today's Flights
10 TodayArr
11 TodayDep
12 TodayDep EI
13 Tomorrow

SQL Wizard

Today Arrival flights
Today Departure flights
Today EI departures

Tomorrow flights v

| LEG ="A" and OPER_DATE = today

| & admin Ig admin |

Figure 74: Database Filters

2. Select/Highlight the filter you want to delete.

3. Use one of the Following methods to delete the filter.
& Select Edit >Delete Filter.

& Click the Delete Filter button.

& Use the keyboard, CTRL+D.

4. Click OK to approve or Cancel to abort the action.
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In order to make a filter operational, you must create a SQL query defining your needs.

13.6.1

Opening the SQL Wizard

1. Open the Filters Window (See Opening the Filters Window on page 79).

3. Database Filters - FLTO_VIEW 3]

File  Edit Help

DX X O
& @ Group: admin v £ Ousen

Name / Description

3 mySAT_flights ~
4 SAT FLTU SAT

5 SAT-Sairlines

& SAT-QF-TG For YISITS linkfunlink test

7 SAT_AIRLINES SAT FILTER

8 Today Flights Today flights

9 Today's Flights

10 TodayArr

11 TodayDep

12 TodayDep EI
13 Tomorrow

SQL Wizard

| LEG ="A" and OPER_DATE = today

Today Arrival flights
Today Departure flights
Today EI departures

Tomorrow flights v

| & admin Ig admin |

Figure 75: Database Filters

2. Select the desired filter.
3. Use one of the following methods to open the SQL Wizard.

™ Click the SQL Wizard button.

& Select Edit > SQL Wizard.

& Click the SQL Wizard button on the toolbar.

4. The Filter Wizard window will open.

S Filter Wizard - FLTO_VIEW (Arrivals) X

SQL Wizard

Operation Field Operator
® AND [
O oR

O no operation

P Insert SQL text

V= v‘

LEG ='A" and OPER_DATE = today

[[] Auto Save

savesqL || checksql |[ cearsal |

I g admin Ig admin l

Figure 76: Filter Wizard
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13.6.2 Using the SQL Wizard

Open the SQL Wizard.

Mark the check box to view
existing parameters.

1.

Dynamic parameters field
includes parameter description

(optional choices etc.)

SQL Wizard (includes Operation,
= Field (list of columns), Operator
data field, etc.)

| SQL like statement (after
insertion, you can add free text)

% Filter Wooard - FLTO_VIEW (Today's Flights) @
[¥]) Show Parsmeters
rtf2) ={1} as Days from today. Ex. | tomirrom, 1 = Yesterday
U wowrd
Cperabion Fulkd Operator
oy ) v - ~
Qor h
O ro cpaeation
~
OPER_DATE = today+000
[] ato Save
Save 54 Chack 58 Cor 58| o [ coxe |
£ o | @ sdwn

Figure 77: Filter Wizard

2. Create a SQL Statement.
For example, if the Today’s Flights filter (Figure

77), shows the whole set of today’s

flights (OPER_DATE = today), but you want to see only the “Arrival” Today’s Flights:

Open the SQL wizard and select LEG from the Field dropdown list.

a.
b. The Data text box will open.
c. The Operator field defaults to “=".
d. In the data field type “A” for Arrivals.
SQL Wizard
Operation Field Operator [h
© Anp LEG v][= v|[a D
Oor - /|
(O no operation
Figure 78: Filter Example
e. Click the Insert SQL text button to insert the SQL statement.
SQL Wizard
Operation Field Operator Data
© AND LEG v = v|[a
OOor

(O no operation

~P AND LEG ="&'

OPER_DATE = today+{0
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Figure 79: Insert SQL Text

3. Check the legality of the statement by using the Check SQL Button.

4. Click OK to save the filter or Cancel to abort the operation.

5. If Auto Save is v'checked, the filter is saved automatically when you click OK.

oK || Cancel I

Figure 80: Auto Save

6. The filtered data will now display using the new SQL parameters.
13.6.2.1 Filter Buttons

Save SQL - Saves the SQL statements that have been inserted, and

leaves the Filter Wizard open.

Check SQL - Checks the legality of the SQL Statements that have been

inserted.
Clear SQL .
Clear SQL - Erases ALL the SQL statements that have been inserted.

13.6.3 Parameters

A filter can have dynamic parameters which request actual values (when the filter is used).

When you use a filter containing parameters, the Query Wizard option allows changing values
and viewing data without the need of using various filters.

When a filter is created, the parameter section of the SQL Wizard is blank.

%. Filter Wizard - FLTO_VIEW (Today's Flights)

Show Parameters

Figure 81: Filter Parameters

Enter the parameters you want to define.

For Example:
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% Filter Wizard - FLTO_VIEW (Today's Flights) 3]

Show Parameters

nt(2) ={1} as Days from today. Ex. 1 tomorrow, -1 = Yesterday;

har(1) choice {Arrival, Departure} as Leg; (R

SQL Wizard

Operation Field Operator Pattern
@® AND LEG v | like v [ar

Oor

(O no operation

~P AND LEG like "1} %' Insert SQL text

PER_DATE = today+{0) AND LEG lke {1}%

[[] Auto Save
| savesq || checksaL |[ cearsar |

| | & admin Ig admin |

Figure 82: SQL Wizard Parameters
The SQL clause is: OPER_DATE = today+{0} AND LEG like ‘{1}%’

and

the parameter is: int(2) as Days from today you will be able to see flights for yesterday if the
value in the Query parameters Wizard is (-1), flights for today if the value is (O) etc. and

char(1) choice {Arrival, Departure} as Leg gives you a drop down list to choose either Arrival
or Departure.

When you select this filter from the Database Filters, the Query Parameters Wizard prompts
you for the dynamic parameter values. The required field for days int(2) is highlighted in pink
and the user must enter a value, however the Leg field is a choice and is optional.
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. Query Parameters Wizand @

Please select query parameters: [[] Details

Days from today. Ex: 1 tomorrow, -1 Yesterday

Leg

Cancel

Figure 83: Query Parameters Wizard

13.6.4 Parameter Syntax Definitions
13.6.4.1 Syntax
<type>[(precision)] [not null] [= {default}] [choice {choice_1[,choice_2 ..]}] as <text>
13.6.4.2 Mandatory Fields

a  type
Can be one of the following: char, int, date, time, dttm

& text
Displayed as a prompt for the user and can be enclosed in quotation marks
13.6.4.3 Optional fields

[not null] - the value has to be defined
[= {default}] - set a default value
[choice {choice_1[,choice_2 ..]}] - choose from a list of values

[(precision)] - the exact length of the field

Different parameters should be separated by a semicolon ().

In a "WHERE" clause, parameters are indicated by parameter number (starting from zero)
included in braces {}.
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Example:
Parameters:
Int as”Days from today. Ex: 1= Tomorrow, -1 = Yesterday”;

Char(1) choice {Arival, Departure} as Leg;

WHERE clause:
Oper_d = trunk(sysdate) + {0} and LEG like {1}%’
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14.0 Customizing Flight Manager

Flight Manager views can be modified using the options menu and filters. The modified views
can then be saved as a custom view that you may open when needed.

You can also customize a view by changing features of the Query Panel and the Action Bar.

14.1 Right-Click Method

1. Right-click the Query Panel or Actions Bar.

%% InterSystems Flight Manager - Primary Flights Scheduling [CurrentSeason] Q@@
g X

File  Edit View Tasks Actions Favorites Tools  Window  Help o
=8 G RBE DFRX Y% 7¢ Q0
A Aitline Flight Mo Valid Dates > Weekdays Exclude
'% 1 [ 1
D <al= v <all> »
O sau f
@ General \Handlers _Bcations (via's) | Belts | Gates | Carousels | Details | Visits
Resourees Flt No Leg, _‘ Info Weekdays Valid From Date Valid To Date Season Name
CX995 & 1234567  26/03/2006  31/10/2006 S06 ~
Right-click in the area you wish to o0 /03/Z00o | 2145012 00°4] 300
change. 567  26/03/2006  31/10/2006 S06
The Query Panel or Action Bar. I 264,03/ 00 CR| 3 1420720058500
.67  26/03/2006  31/10/2006 S06
s |le CIOS3 & 2.45.7 26/03/2006  31/10/2006 S06
7 CIOS4 D 2.45.7 26/03/2006  31/10/2006 S06
Scheduling || 2 CX10z D 3..6 26/03/2006  31/10/2006 S06
3 CX10z D 12.45.7 26/03/2006  31/10/2006 S06
E=E 10 BIO7L D [\  [..... 6. 26/03/2006  31/10/2006 S06 oy
— < >
DB Table
..+ {additional information) 1442 rows
[ ] |[ validate all |
| & admin | € admin |
Figure 84: Right-Click View Customizing
2. An “Options” (context sensitive menu) opens
Options Options
v Show Query Panel v Validate
v SQL v VYalidate all
v Leg Pause Validate Al
v Aitline Resume Validate Al
v Flight No . .
d Figure 86: Action Bar
v Valid Dates
v ‘Weekdays
v Exclude
v Season
v Visit
Figure 85: Query Panel
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3. Use the mouse button to mark or unmark different options.
14.2 Changing View Options

1. Select Tools >Options.

2. The Options window will open.

@ Options

= Preferences
Query Panel
Actions Bar

Flights

Gates Usage

Belts Usage

Carousels Usage H

Desks Allocations FI Ig ht M a nage r

Primary Flights Scheduling

Codeshares Scheduling

Visits Scheduling

Desks Scheduling

Figure 87: Options Window
3. On the leftis a list of all the Flight Manager views.

4. Click a view to see the available Query Panel and Action bar options.

{@ Options
=+ Preferences
uery Panel
t Query Panel Q ry
Actions Bar .
v| Flight Types
Flights SAS T
e o Flteo
Actions Bar Date
Gates Usage ;.
Belts Usage GI
Carousels Usage Flight No
Desks aAllocations Locations
Primary Flights Scheduling
Codeshares Scheduling Gate
Visits Scheduling [ Belt
Desks Scheduling [ Carousel
Remark
isit

Figure 88: Adding Options

5. Mark or unmark the options/buttons you desire for a view.
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dedicated options can be added to the Desks and the Flight scheduling views.
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To view the new changes, click the required task again.

14.3

Preferences

Preference settings are saved on your workstation and cannot be saved as part of a custom

view.

1. Select Tools >Options.

2. The Options window will open.

3. Click Preferences.

Options

- EEEEIED Preferences
Query Panel
Actions Bar

#-Flights Show Tasks

+- Gates Usage

+ Belts Usage Auto Save

+ Carousels Usage Move Selection After Enter
+-Desks Allocations Direction:

+ Primary Flights Scheduling e e e
+ Codeshares Scheduling

+ Visits Scheduling Grid Font Size: D (8-22)
+ Desks Scheduling

Figure 89: Preferences

4. Select your desired preferences.

) 3

) 3

Show Tasks - Toggle the Task Bar On or Off
Auto Save - Turn Auto Save on or off.

Move Selection After Enter - The direction that the cursor will move in grid view
after the Enter key is pressed.

Show Memory Resources - Display memory usage at the bottom of the Flight
Manager window. The Garbage Collection button is used to reclaim unused
memory.
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£ admin ﬁ admin || 12561KB (19%) of 14MB [max. 63ME] c',"..i

Garbhage
Memory Usage Collection

Figure 90: Memory Resources

& Grid Font Size - Change the Grid View font size (default size is 11).

14.4 Query Panel Preferences

Use this option to set the display preferences and SQL history Size.

1. Select Tools >Options.
2. The Options window will open.

3. Click Preferences 2 Query Panel.

@ Options

= Preferences
t Query Panel
Actions Bar

Flights

Gates Usage

Belts Usage

Carousels Usage View Query Panel

Desks Allocations Yiew SQL

Primary Flights Scheduling SQL History Size: D (0-30)

Codeshares Scheduling

Visits Scheduling

Desks Scheduling

Figure 91: Query Panel Preferences

4. Select your desired preferences.

14.5 Saving a Custom View

A customized view is saved on your local drive (the default save location is the My
Documents folder). The view saves column properties (like column width) and last used filter.
You can make changes to the view at any time and save the new view with a customized

name in order to identify the view later.

To save a view:

—_

Select File >Save View.

2. A folder located on your local drive opens.
3. Enter the desired file name.
4. Click Save View As....
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14.6 Opening a Custom View

To access customized views:

—_

Select File > Open View.
A folder located on your local drive opens.

Select the desired view.

ENFN

Click the Open View button.
14.7 Adding Views to Your Favorites

To add frequently used views to your favorites:
1. Select Favorites >Favorites Add.
The My Documents folder opens.
Choose a saved Custom View (.ucv extension) to add to your favorites.
Click OK.

QI NN

The Custom View is added to your favorites menu.
14.8 Opening a Favorite View

To open a favorite view:
1. Select Favorites.

2. Click the desired view.
14.9 Deleting a Favorite View

To delete a favorite view:
1. Select Favorites - Favorites Organize.

2. The Favorites Organize window opens.

Favorites Organize @
John_ Flights

John_desks
John_scheduling

Figure 92: Favorites Organize
3. Select the view you want to delete from the dropdown list.
4. Click the Delete button.
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15.0 Rearranging Views

You can adjust the way Views display in Flight Manager by tiling, cascading or resizing the
Views and gridlines.

15.1 Resizing Windows

1. Place your cursor over the edge of the window.

2. The cursor will change to a double headed arrow

% Flight Manager... L—\f[

FEViTéeAcFaTcWiH - & X

-BaBRE0D

A Yisit
Comments/Remarks

Flichts .-+ (additional information]

— g.g.

Figure 93: Resizing Windows

3. Once the double headed arrow is displayed, click and hold down your mouse button

4. Drag your mouse in the direction you want the window to be resized.
15.2 Resizing Gridlines

The height and width of records and the height of timelines can be adjusted.

Move your cursor over the appropriate dividing line as shown in
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File Edil Viev Tast Actio Favor Too WindiHel = & X

=B RMBDETRXYT

—_

Figure 94.

ENFN

A

v

|

: (additional information)

A Comments/Remarks Yisit
Carousels Desks Details
ions (via's) Belts | Gates
Flights General | passengers Info | Handlers
Oper Date Flt No Leg <
@ 2005 ER431 & 1Al
2 @ 2005 DJOOS D 1=
Resources |3 |1 7peZ/z005 ER430 D ¥l

15 rows

|£ ad...[g ad..,|

Your cursor will turn into a double headed arrow.

across to adjust the width of the resource text.
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Once the double headed arrow is displayed, click and hold down your mouse button.

Drag your mouse down or up to adjust the height of the resource or the time line, or
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. Flight Manager - Flights [Today: [£|[8[X]

File Edil Viev Tast Actio Favor Too WindiHel = & X
>-B3RREBDYDXYT

Comments/Remarks Yisit

Carousels Desks Details

ions (via's) Belts | Gates

Flights General | Passengers Info | Handlers
Oper Date Flt No Leg <
@ 1 z005 EK431 A 1Al
2 @ 2005 DJOOS D 1=
Resources |5 ) Ppe?/2005 EK430 D v

l% ..+ {additional information) 15 rows

>

| [2 o0 8 o

Figure 94: Resizing Gridlines

15.3 Tiling Windows

To display windows in a tiled formation choose one of the following.

& Select Window - Tile.
B Select Window > Tile Horizontally

& Select Window - Tile Vertically.

15.4 Cascading Windows

To display windows in a cascade formation:

& Select Window - Cascade.
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16.0 Changing Your Password

The security password that you use to access RapidAIMS can be changed from within the

program. This option is not available to all users.
1. Select Tools » Change Password.

2. The Change Password Assignment dialog box will open.

% User Password Assignment @

£ User: admin

MNew password \ Aokokskodokok ‘

Confirm password [ Attololiok| ]

Figure 95: Change Password Dialog Box

3. Enter your new password.
4. Enter your new password again to confirm the change.

5. Click the Enter button to save your new password.
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17.0 Getting Help

On-line help can be obtained in the following ways:
& Select Help & Contents and Index.
& Press the F1 key on the keyboard.
Flight Manager Help operates as a standard Windows help facility.
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18.0 Menus, Toolbars and Shortcut

Keys

Menu Command Button Shortcut Description
Keys
File
@ CTRL+O | Open a Custom View.
: Use to select a System View set by
| Open System View | None None the system administrator (System
View page 19).
None CTRL+F4 | Close the current view/window.
None None Close ALL views/windows.
B save CTRL+S | Save changes.
None None Save a custom view.
None None Save a custom view with a new
name.
4 Print CTRL + P | Print ALL the data in a view.
- Preview data to be printed. Also
|_-L Print Preview | = None used to select single pages to be
printed.
None None Exit Flight Manager.
Edit
CTRL+C Copy a record.
CTRL+V Create a new record by pasting
l:"@y information copied from another
flight.
Insert Flight None Create a new record.
O Edt Fight CTRL+E Edit selected record.
@ None View selected d information.
x Delete Flight CTRL+D Delete a record.
Auto Save None None Toggle the Auto Save option “On”

or “Off”.
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Menu Command Button Shortcut Description
Keys
View
CTRL+R Open the Filters Window.
= Unsorted None None Remove sorting from grid view.
None F4 Open the Query Wizard.
@ Refresh F5 Refresh the Grid View.
|Show Query Panel | None None Toggle the Query Panel On or Off.
None None Toggle the Task Bar On or Off
Tasks
“ None Open a Flights View
Flights
e, None Open a Resource View (Gates,
Esourees @ Belts or Carousels).

Resources

|ﬁ Desks Allocatlons| None Open the Desks View.
= None Open a Scheduling View (Primary
] Scheduling = Flights, Codeshares, Visits and
— Desks).
Scheduling
=1 DB Table = None Open the DB Table View.
DB Table
Actions
None Open the Gate for a flight.
None Set boarding status for a flight.
Last Call None Set Last Call status for a flight.
None Set the Close status a Gate.
None Step the time for the first bag on a
belt.

| Belt Last Bag | None Step the time for the last bag on a

belt.
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(2] Contents and Index

Menu Command Button Shortcut Description
Keys
| Carousel First Bag | None Step the time for the first bag on a
carousel.
Carousel Last Bag None Step the time for the last bag on a
| l carousel,
None Validate a Flight schedule.
validate al validate Al None Validate ALL flight schedules.
Load Flights From None None Run a Flight Load. Restricted to
Schedule Administrators
Configure Flight Load None None Configure Flight load. Restricted
to Administrators
None Open Desk Details View.
|W| None Set the actual date/time the desk
| te ) opened.
@l None Set the actual date/time the desk
closed.
& Link None Link a flight to another flight.
None Unlink a flight.
Favorites
None None Add a Custom View to your
Favorites.
|Favorites Organize | None None Used to remove a Favorite View.
Tools
| Changs Password | None None Change y_ou password used to
access Flight Manager.
None None Set options for the Query Panel
and Action Bar.
None None Tile windows.
E Tile Horizontally None None Tile windows/views horizontally.
[T] Tile Vertically None None Tile windows/views vertically.
B Cascade None None Cascade the windows/views.
Help
F1 Opens the Flight Manager Help

files.
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Menu Command Button Shortcut Description
Keys
|_ - None None Displays information about the
filncuk Figh Meoager software version and release date.

Table 2: Toolbar Buttons and Shortcut Keys
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19.0 Glossary

Terms Definition

AIMS Airport Information Management System
AODB Airport Operational Database

AQ Advanced Queuing

AS Application Server

CM Configuration Manager

CUTE Common User Terminal Equipment
DB Database

DBI Database Interface

DBP Database Proxy or Processes
DDL Data Definition Language

DML Data Manipulation language

EJB Enterprise JAVA Beans

EM Event Manager module

ERD Entity Relational Diagram

FIDS Flight Information Display System
FLTO Flight Object

FLTU Flight Utility

FM Foundation Modules

FMG Flight Utility

GClI Generic Communication Interface
GDB Generic Data Browser

GUI Graphical User Interface

18n Internationalization

IS Installation Solution

IT Information Technology

IVRS Interactive Voice Response Systems
J2EE Java'™ 2 SDK, Enterprise Edition
JDBC JAVA Database Connection

JMS Java Messaging Service

JNI Java Native Interface

LA Logging Administration Utility

LH Logging Handler

Page 103 of 108

RapidAIMS Flight Manager USM- v 5.3.4

Copyright © InterSystems 2011



»

systems

‘ ingenious by design

MCI Master Clock Interface

Natural key Distinguishes entity occurrences to avoid duplicates.

NDC Nested Diagnostic Contexts

0oCc4J Internet Application Server

OEM Original Equipment Manufacturer

OLAP Online Analytical Processing (Multidimensional Database)

(O Operating System

Primary key A physical design element that allows us to establish relationships between
data in the database.

QC Quality Control

RAIMS Rapid AIMS

RapidACIS InterSystems, Airport Commercial Information Solution

RapidACIS InterSystems, Airport Commercial Information Solution

RapidADS InterSystems, Advertising Display Solution

RapidAIMS InterSystems, Airport Information Management Solution

RapidBIDS InterSystems, Baggage Information Display Solution

RapidBILLS InterSystems, Billing Information Solution

RapidFIDS InterSystems, Flight Information Display Solution

RapidGATE InterSystems, Airport Resource Management Solution

RMI Remote Method Invocation

SCHFLT Scheduling Flight Module

SuU System Utilities

UM User Management

XML Extensible Markup Language

XSL Extensible Style-sheet Language
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20.0 Index

A Data Entry, 25

- Symbol, 27
Action Bar, 20 + Symbol, 27
Customizing, 84 = sign, 26
AIMS, 97 Actual Time, 26
Airline Staff, 6 Copy/Paste, 29
Airport Operations Staff, 6 Data Types, 25
AODB, 97 Date/time Fields, 26
Auto Save, 21, 36, 74, 86, 93 Date/Time Shortcuts, 26
Entering Dates and Times, 25
B Estimated Time, 26
Belts, 8, 44 Keywords, 26
. Mandatory Fields, 25
Assigning, 45
L n..., 27
Editing, 46
) now, 27
First Bag, 94 . .
Numeric Operations, 26
Last Bag, 94 -
. Scheduled Time, 26
Opening, 44 .
S Special Symbols, 26
Viewing, 46
. t..., 27
Boarding, 94
Bulk Deletes, 24 today, 27
’ Valid Values, 25
C Data Types, 25
Alphanumeric, 25
Carousels, 8, 46 Date, 25
Assigning, 47 Datetime, 25
Editing, 48 Integer, 25
First Bag, 95 Time, 25
Last Bag, 95 DB Table, 13, 71, 94
Opening, 46 Deleting a Record, 72
Viewing, 48 Editing a Record, 72
Codeshares, 11, 61, 62, 63 Inserting a Record, 72
Editing/Viewing, 62, 63 Opening, 71
Flights, 61 Viewing a Record, 73
Scheduling, 11 Deleting a Flight, 38
Comments/Remarks, 8 Deleting a Record, 24
Copy, 29, 35, 93 Desks, 8, 9, 49, 51, 52, 54
Copy/Paste, 29, 34 Allocation Scheduling, 67
Customizing Allocations, 9, 51, 94
Actions Bar, 84 Assigning a Carrier, 50
Query Panel, 84 Assigning a Class, 50
Customizing Views, 85 Assigning a Flight, 50
Delete a Scheduled Allocation, 70
D Desk Close, 95

Desk Details, 49, 95

Desk Open, 95

Edit a Scheduled Allocation, 69
Editing, 52, 54

New Desk Allocation, 51

Daily Flights, 10
Data
Sorting, 74
Un-sorting, 74
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New Scheduled Allocation, 68
Opening, 49
Scheduling, 67
Viewing, 52, 54
Working With, 49
Detail View, 21
Drop Down Lists, 27

Edit, 38
Editing
Grid View, 21
Entering Dates and Times, 25
Exiting Flight Manager, 17

F

Favorite View
Deleting, 88
Favorites Add, 88, 95
Favorites Organize, 88, 95
Open, 88
Filters, 15, 32, 75, 94
Creating, 76
Defining SQL, 79
Deleting, 78
Editing, 77
Filtering, 6
Opening, 75
Parameter Syntax Definitions, 83
Parameters, 81
Selecting, 75
SQL Wizard, 79
Flight Candidate Rules, 41
Flight Information, 20
Flight Manager, 16
Exiting, 17, 93
Functionality, 8
Login, 17
Starting, 16
System View, 14
Views, 14
Flights, 32, 94
Copy/Paste, 34
Daily Flights, 10
Deleting a Flight, 38, 93
Details, 8
Edit Flight, 36, 93
Flight Candidate Rules, 41
Flights Screen, 8, 32
Flights Screen Open, 32
Insert Flight, 33, 93
Linking Flights, 38, 39, 95
Locations (via’s), 9

New Flight, 33
Passengers Info, 9
Unlinking Flights, 40, 95
Updating a Flight Record, 36
Validate, 95
Validate All, 95
Validating a Single Flight, 58
Validating All Flights, 58
Validation, 57
View Flight, 93
Viewing Linked Flights, 38
Flights Screen, 8
Font Size, 87
Changing, 87

G

Garbage Collection, 86

Gates, 8, 42
Assigning, 43
Close Gate, 94
Editing, 43
Viewing, 43

GDB, 97

General, 8

General Operators, 6

Grid View, 18
Editing, 21
Font Size, 87
Sorting, 20

GUI, 6

Handlers, 8

Help, 92, 95
About Flight Manager, 96
Contents and Index, 92, 95

Insert Flight, 33
Internationalization, 6

K

Key Concepts, 8
Keywords, 27
now, 27
Numeric Operations, 26
today, 27

Last Call, 94
Linking Flights, 39
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Flight Candidate Rules, 41
Login, 17

M

Mandatory Fields, 25
Manual Refresh, 23, 94
Memory Resources, 86
Midnight, 25

New Flight, 33
now, 27
Numeric Operations, 26

o

Open
Open System View, 93
Open View, 93

Open Gate, 94

Options, 95

Password

Changing Password, 91, 95
Paste, 29, 35, 93
Preferences, 86
Primary Flight

Editing, 59, 60

Viewing, 59, 60
Primary Flights

Scheduling, 10
Primary Flights, 10
Printing, 30

Print a Selection, 30

Print All Pages, 30

Print Button, 93

Print Options, 30

Print Preview, 30, 93

Q
Query Panel, 19
Customizing, 84
Query Wizard, 94
R

RAIMS, 98

Refresh, 23, 94

Resources, 42, 94
Belts, 44
Carousels, 46
Gates, 42

»

systems

‘ ingenious by design

Opening Resources, 42
Screens, 9

Row Identification Number, 20

S

Save, 93
Save View, 93
Save View As..., 93
Scheduling, 56, 94
Codeshares, 11, 61
Desks, 67
New Codeshare Flight, 62
New Desk Allocation, 68
New Flight, 56

Primary Flights Scheduling, 10, 56

Scheduling Screens, 10
Validation, 57
Visits, 11,13, 63
Security, 6,17
Selecting
Adjacent Rows, 24
Nonadjacent Rows, 24
Show Query Panel, 94
Show tasks, 94
Show Tasks, 86
Sorting
Grid View, 20
Sorting Data, 74
Sorting Information, 20
Special Symbols, 26
- Symbol, 27
+ Symbol, 27
= sign, 26
sQL, 9,19, 79
Field, 19
Wizard, 79
SQL Wizard, 79
Parameters, 83
Using, 80
Starting Flight Manager, 16

Switching Between Views, 23

System Administrators, 6
System Information, 20
System View, 14

Tasks Bar, 18
Title Bar, 23
today, 27

Tool Options, 85
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U Open View, 88, 93
Rearranging, 89
Resizing Gridlines, 89
Resizing Windows, 89
Save View, 87, 93
Save View As..., 93

Unlinking Flights, 40
Unsorted, 94
Un-sorting Data, 74

v Selecting the Detail View, 21
Validation, 57 Switching Between, 23
Validating a Single Flight, 58, 95 System View, 14
Validating All Flights, 58, 95 Title Bar, 23
Views, 15, 18, 23 Visits, 9, 11, 13
Close, 93 Scheduling, 11,13, 63
Close All, 93
Custom View, 87 w
Customizing, 84, 85, 86, 87 Window Structure, 18
DB Table, 13 .
Deleting a Favorite View, 88 Windows
Hng ’ Cascading Windows, 90, 95
Detail View, 21 o
. . Resizing, 89
Favorite View, 88 .
Tile, 95

Favorites, 88
Favorites Add, 88
Flights View, 32

Grid View, 18, 20
Manual Refresh, 23
Open System View, 93

Tile Horizontally, 95

Tile Vertically, 95

Tiling Windows, 90
Wizard

SQL, 79
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